Duplicate MAC Addresses and Serial Numbers

Can you paste full printing log for us? Just worried you ran the command on Linux, it should be on U-Boot.

Have fun!

What ja u bot… i have a debian.

I meant U-Boot, the booloader of any Linux Distro(Ubuntu, Debain…)

So you ran the command on Linux, right? Should be on U-Boot :wink:

Hello Emill,

What image you use? If you use linux image provided by us or Armbian by balbes150, you can try the following commad on linux command line:

$ sudo fw_setenv ethaddr “00:15:18:01:81:32”


VIM1_Ubuntu-xenial_Linux-3.14_mate_arm64_EMMC_2018-05-31.7z 2018-07-12 02:34 686M

i have fresh ubuntu, errors:

not working

anyone? bump…

Can you have a try on this, note to run on U-Boot:

how run u-boot?..

It’s common methed, check follow docs for the details:

I’m learning, so you have to explain how for a fool … I’ll check it out when I ask something. Thanks.

$sudo apt-get install openbsd-inetd tftpd tftp
tftp (tab) dgram (tab) udp (tab) wait (tab) root (tab) /usr/sbin/tcpd (tab) /usr/sbin/in.tftpd -s /srv/tftp
write, SAVE OK

$sudo mkdir /srv/tftp
$ sudo chown -R gouwa /srv/tftp

$sudo /etc/init.d/xinetd restart
command not found

$/etc/init.d/xinetd restart
no such file or directory

this guide is incorrectly written

$apt-get install xinetd
$/etc/init.d/xinetd restart

$sudo setenv ethaddr “00:15:18:01:81:32”
command not found

not working

You still working on Linux/Ubuntu, not U-Boot :joy:

what did I write above? I have ubuntu… and you write uboot uboot and uboot all the time …

I do not have the strength to do it anymore, you do not help … I return to raspberry pi, there are no problems, I only wish I have 20 khadas bought, but I will refund

Nobody can help you out if you don’t want to give a try.

Actually, Ubuntu also include a U-Boot as bootloader, please follow the instructions I told you to take a try and update us if further questions.

Good luck!

i try all the time, bot WHAT IS U BOOT system? how use uboot on ubuntu if is not system… no body told me here

tell me HOW change mac address on <<<<<<<<<<< UBUNTU >>>>>>>>>>> not UBOOT, i have UBUNTU. u see now what system i have?

setenv ethaddr “00:15:18:01:81:32”


read my all posts again i try all the tiem

You’ve been given 3 working options - they all work with an Ubuntu based board - ive used them all!

  1. in the file /etc/network/interfaces add a line hwaddress ether XX:XX:XX:XX:XX:XX where XX is your MAC address. Reboot to get it to pick up the MAC
  2. sudo fw_setenv ethaddr “00:15:18:01:81:32” that sets uboot variables from the ubuntu command line
  3. go into uboot - @Gouwa gave you the links, just need to follow them - get a serial to usb adaptor connected as per https://docs.khadas.com/vim1/SetupSerialTool.html then from a serial console on your pc press space whilst the board is booting at you will halt boot at the u-boot prompt then you can use the command - setenv ethaddr “00:15:18:01:81:32”

If you dont know what something is then you can just google it - https://en.wikipedia.org/wiki/Das_U-Boot


Hi Emill:

  • Ubuntu or Armbian is an Operating System
  • U-Boot: is a bootloader, not an Operating System, check the link birty replied above for the details.
  • All Operating System will require bootloader/u-boot, and the UBuntun you install also with a U-Boot

Have fun!

okey, now i know what i u-boot, tell me how install u-boot with system? i have files, but dont know how use in ubuntu.

Uboot is already installed, it’s what loads Ubuntu for you. Personally I would ignore uboot and use either option 1 or 2 that I put above. Both of them work from within Ubuntu


Method 1 not working, i try many times, many methods.
Method 2
$sudo fw_setenv ethaddr “00:15:18:01:81:32”
without mistakes but without results

Method 3 i don have this device :confused:!

after restart i have another mac, next restart next mac