Display resolution in Ubuntu on VIM3

I just installed Ubuntu on VIM3 (from VIM3_Ubuntu-gnome-focal_Linux-5.7-rc7_arm64_SD-USB_V0.9-20200530.7z.) Maximum resolution is set to 1920x1080 but my monitor is 3440x1440. How can I change the resolution? I tried setting it in /boot/env.txt. Also tried script I found in the following post: How to change the display resolution of the Ubuntu on VIM3. Also found “HDMI resolution” GUI gadget. None of these three methods work. I also noticed that /usr/local/bin/hdmi.sh script is actually empty, and it looks like this is were the actual commands should be.


Please check “Applications->Settings->Displays->Resolution”


Under this setting the maximum resolution is 1920x1080, which is far lower then the resolution of the monitor.

I tied to manually set resolution by running the following command:

sudo fbset -fb /dev/fb0 -g 3440 1440 3440 1440 32

It returns an error “ioctl FBIOPUT_VSCREENINFO: Invalid argument”

Also looking in sysfs the file /sys/class/drm/card0-HDMI-A-1/modes only list resolutions up to 1920x1080.

So what is the maximum resolution supported by VIM3 hardware?


Hardware can support up to 4K60, this maybe a software issue.

I tried with Ubuntu-xfce-bionic-5.5 with the same result. I also run the following command:

edid-decode /sys/devices/platform/soc/ff900000.vpu/drm/card0/card0-HDMI-A-1/edid

and it returned mode 1920x1080 as highest resolution, and also marked as “native”. I believe that HDMI on VIM3 does not read monitor edid correctly. Is there anything can be done about it, otherwise this board is not usable to me.