Connecting TS050 to VIM3L

I have a new VIM3L and a new TS050 touch panel
I can see a diagram where to connect the display’s ribbon cable to the VIM3L - to the DSI and TP connectors.
However, I do not know how to actually connect the cable.
I am looking at the connectors under a magnifying glass and I don’t know if there is a latch or something that I need to open.
I cannot find any instructions.
Are there any video or diagrams showing how to actually open/unlock, close/lock these?
I don’t want to damage anything

The connection method is shown in the figure below

I have seen that picture thank you.
But my question is HOW to insert the cable and lock it in - are there latches etc.
Everything is too small for me to see how the actual connector works.
Do I just push the cable really hard and it will go in to the slot, or do I have to open / unlock something in the connector before I slide in the cable, and then lock it after?
Any clear instructions / description appreciated thank you

Hi @gar1234, please pay attention closely:

I have provided some high quality photos to visualize each step you are going through.

  1. Make sure you have the right FPC connector for VIM3/3L

  1. Identify which connectors you will need to open (the DSI and TP connectors)

  1. You need to gently lift the black color hinge piece with your fingernail to a 60-70 angle off the board. Gently apply force in the middle of the connector, and importantly lift upwards!

preferably place your fingernail under the place highlighted.

  1. Insert the fpc cable inside both the connectors. you will know if the connector has reach its max insertion depth if you see the glossy black part of the cable with the edge of the SBC.

  1. finally, hold the FPC cable in place and fold back the connector trying not to apply much pressure, just ensure the hinge is folded parallely to the board. (refer the above image)

Just follow the steps, and you will have ensured connection, do not try to tug on the cable to ensure connectivity.

If you see any sort of distortion, freezing, screen suddenly goes dim. swiftly power off the device and repeat the procedures to re seat the connection.



Hi - those are great instructions thanks.
I have had about 10 tries so far, and always with the same result - a streaked green screen.
I have attached some pics but I can’t get a clear photo of the connectors.
Do you have any other hints / advice?

(I know the VIM3L is working, because if I connect a monitor via HDMI I get the Khadas logo, followed by the Android start up screen).

Hello, I think you may be using the latest firmware. The TS050 has been updated later. If you upgrade the firmware to the latest one from the official website, it should be displayed normally.

  1. I assume the image I need to work with is vim3l-android-9-64bit-v230725.img
  2. I downloaded the USB Burn Tool and loaded in this image
  3. I pressed the Function button 3 times quickly, to enter Upgrade Mode - I saw the blue LED flash, once, then twice, then twice, but then back to the White LED (on/off every 2 second)
    So I assume it is not going in to Upgrade Mode
    The USB Burn Tool doesn’t display any device

Note: I don’t think my PC is supplying enough power to the board - I think the board keeps resetting.
But how else can I get the device in to Upgrade mode?
I tried powering the board via my USB-C adapter, which supplies 12V etc, and then connect the PCB USB port to the USB 3.0 port on the board. When I pressed the Function button 3 times, the Blue LED went once, then twice, then the Red LED flashed once. I clicked Refresh in the USB Burn Tool, but it did not detect any device. About 30 seconds later, the Red LED went on again, but stayed on forever.

@gar1234 when using the burn tool, disconnect the screen and any peripherals if connected, nothing must be connected (cooling fan is ok).

make sure you are using this version tool:

I have nothing else connected to the board - just USB-C power/connection from the PC.
I am using the version 2.2.0 burn tool.
The problem seems to be that the PC does NOT provide enough power to the board
If I power the board from my 24W USB-C supply, the board turns on and the white LED stays on, solid.
However, if I power the board from my PC instead, the white LED toggles every 2 seconds approx.
So it looks like the board is resetting every 4 seconds.

So if I power the board from my 24W USB-C supply, how can I put the device in to Upgrade Mode?

@gar1234 You can try using an SD card/USB disk to burn oowow onto. then connecting this oowow disk and a hdmi cable, with peripherals to a screen you can manually update without the need of a computer.

this is the other alternative if your laptop is unable to provide ample power and you require the usage of the power adapter.

You need a very stiff power supply with good regulation. The official khadas supply should work fine. If not cut the connector off the USB cable and connect to lab power supply. Braid is negative and the large diameter wire is +. If your cable only has small diameter wires that is your problem, cable must be rated for at least 5 amps.

I burnt an image of OOWOW (board.VIM3L.time.1678233600.size.17065722 .SIZE.67108864.ver.230308.000.oowow-sd.img) on to an SD card
(I initially tried with a USB stick but that didn’t work)
I was able to get the board to launch OOWOW and form there, following the wizard, I was able to download an Android 9 image and install it etc.
Two things:
1 - there was only one image for Android 9 available (vim3l-android-9-64bit-v230130.raw-img.xz) which is a lot older than the image you first suggested I used

2 - after rebooting etc. and connected the TS050 screen, I got the same result (streaky green screen)

@gar1234 In that case you will need to take a copy of the new android image, place it on a USB disk formatted to exFAT. and connect this to the device running oowow.

you can navigate to the “write to eMMC” menu and select the android image from your disk which would be the latest version.

Additionally can you disconnect and reconnect the FPC cable connectors on both ends of the VIM3L and TS050 connection. make sure to seat the cable properly with right alignment, sometimes I may not be properly aligned.


I tried both suggestions

Suggestion 2: Disconnecting and reconnect cable at both ends - I still get the green streak screen

Suggestion 1: I formatted a USB drive to exFat and copied the “vim3l-android-9-64bit-v230725.img” to it.
And I still had my SD card with “board.VIM3L.time.1678233600.size.17065722 .SIZE.67108864.ver.230308.000.oowow-sd.img” burned to it
So I inserted the SD card, and the USB stick and powered up
You can see from the images below that it detected the USB drive but it didn’t find anything on it
What did I do wrong?
Here’s what I see when I power up:

And when I go up a level:

And then down one level in to the USB:

This is taking so long just to get the basic configuration - board and screen - up and running!

More images - when I insert the USB drive back in to my PC:


@gar1234 you need to have the version of the image that has .img.xz as the file extension, that’s what will be usable by oowow to flash the image the eMMC, plain .img disk images won’t be detected.

32 bit OS:

64 bit OS:

I have to give up now
I tried so many images
They all said they were untested, and they all resulted in nothing
After I reboot (SD card removed), with monitor - blank screen - nothing
What is going on???

@gar1234 I will ask other developer to check on it.

@goenjoy can you please verify if any of the images support the operation of TS050 ?

Hello, I cannot use Aml_Burn_Tool_V3.2.0 to burn the firmware. Follow the instructions below to check and reinstall. It may be that the step is missing and the connection success cannot be displayed.

Point 1
I clicked on the link and clicked on the USB Upgrade Tool to download it.
I can see that the download started in my download folder (Windows).
Size “so far” is 82,480 KB.
This download started over one hour ago!
(Note: I had previously tried downloading this file, with similar results – I waited half an hour that time – and then I restarted my PC and tried again).
Is there really a file there at that link? Why can’t I download it?

Point 2
Even if I did (somehow) manage to download this tool and install it, it looks like I would have to run it while powering and communicating with my board, all through the PC’s USB-C port.
If you scroll up through this forum post, you will see that I cannot do that.
The PC is not supplying enough power, which is why I had to eventually use the OOWOW resource.
So I am possibly wasting my time.
(Although at the end of the Upgrade Using USB-C Cable page it states “An External Power Supply may be required in cases where your PC cannot provide enough electrical power for the burning process” – how is that possible when using the tool through the board’s USB-C port?)

Point 3
When I was using the oowow resource, why did all the images I tried say “This image maybe not suitable for WIM3L”. All the images have VIM3L in their file name. And none of them worked.

Point 4
I am getting extremely frustrated.