Cannot boot krescue after android tv install

I must admit, i really hate sbc… Since i bought the vim3 this board is seriously driving in the edge of insanity.

I mean as i tried this thing with the different firmware, i discover nothing is working fine. So a little background of my (many) (yes i say many) problems :
First i bought the vim to be a SIMPLE mpd server, so i don’t need any DE, don’t need X or graphical interface, so all i need is an ubuntu or debian minimal/server. To be clear, no ubuntu or debian image are working… and it become worse with the most recent version to the point of being completely unusable. In fact the only one that is barely usable is the very first ubuntu with kernel 4.whatever.
Also for an unknown reason, when ubuntu is installed the vim sometimes get completely lost and do not recognize the emmc partition, and wait endlessly for some kind of net boot. After 40 or 50 time to reboot the vim it finish by boot again ubuntu. But as i said ubuntu by itself is so rubbish so it’s not a great lost. For example i want to compile the last mpd, except the ffmpeg dev library are broken and it’s impossible to compile.
Last thing to complete a great ubuntu experience, ethernet is often not working, don’t ask me why, reboot several times and to make it finally work.
But hey, it’s not only ubuntu. I mean, try to use krescue for example. I tried so many times the wizard function : ethernet is plug in. Well it doesn’t recognize my Ethernet connection… unplug and plug again and not much change, same for the wifi, sometimes is doesn’t work, who know why. But i would say ethernet work 1 time over 10, wifi 6 time over 10, so i use wifi.
So more recently the great manjaro linux come to the vim3. I was very pleased because it’s my daily distro in all my pc so it was most probably my savor. And i wasn’t disappointed, no more net boot loop of the death, i could compile mpd and mympd easily with aur, no more broken dependency, ethernet is working (kind of, see next). So i used manjaro for the last month as my mpd server.
But there is still strange things and incomplete function that ended to bore me.

First the WOL do not work, and know i can call khadas a liar. It is a supported function, it is in the datasheet of the board, i bought the vim3l because i wanted this function. And this function doesn’t work, thx khadas. I would even say this function is related to other extremely buggy things in the boot loader of the vim.
When i was running ubuntu, i activate the wol in krescue. When the vim is off, if you plug the power cable, the led turn blue. WOL is working, you can turn on the device. Then in ubuntu, just power off with a shutdown now command. The vim shutdown, but the led did not turn to blue, it’s off (or white i don’t remember, but i think it was off). WOL do not work anymore, do whatever you want… The only thing to make it work again is to unplug and plug again the power cable.
With more recent version of krescue, things seems to have changes. Now when krescue boot it asks to disable WOL for some obscure reason, and if i remember i tried to keep it on but got a ton of problem to install manjaro.
In a previous topic khadas vaguely explain an history of uboot from khadas vs a uboot mainline. But again, no explanation whatsoever anywhere, only one uboot image in the khadas repo, and no answer to my solicitation to give me a link have convinced me to stop bothering for this WOL thing.
However what is still strange is the behavior of the vim, even with manjaro. When i plug the power cable, power on and boot manjaro i never had any problem. If i do a sudo reboot, it works… but not always. The vim reboot, but often i wait for him to appear in the network to connect with my mpd client. Nothing. Hell ! I never tried to plug an hdmi cable to know exactly where the problem is, if this is a problem with the ethernet that doesn’t work of the system that fail to boot. I just unplug the power to have this blue light, it always work with the blue light… In the contrary, when the system was power down once, no more blue light, and powering it again is a gamble… So i gave up trying, when i power off i just always unplug and plug again the power cable if i want to power on again. You can say anything khadas, this behavior is strange and not normal for your product. A end user like me shouldn’t battle your product that hard.

So all these little things convince me to curse the name of vim for ten generation and sacrify some young and beautiful girl in the moonlight to curse the name of khadas (told you this thing is driving me insane).

My mother just needed a new box to watch tv, i found here the perfect solution to get rid of the evil thing and regain some sanity.

So i decide to give android tv a try, as it was suppose to be the right OS for tv. I flash krescue again, boot it and as always ethernet do not work (almost forgotten, after all i didn’t had to flash the vim for several month…). After setting up the wifi there is two choice of OS for android TV. Again some end user like me would really (REALLY) appreciate to have an explanation somewhere… After searching in internet i tried the CE version. Seems to be a rom by a forum user, but it is a little outdated. I don’t know if the other version is official and if it can be updated, but as again there is no explanation anywhere…
After installing the CE ATV, well it works… even if the horrible interface of ATV and the fact that all app design to watch the specific tv provider for my mom are complete garbage. I ended trying to install kodi on ATV, and it appear there is a kodi extension that is the only usable thing.

As i won’t keep ATV when only kodi is needed, i tried to flash coreelec or whatever. So after this novel we finally arrive to the subject of this topic. Problem now it is just impossible to boot again to krescue.
If i insert the sd card with krescue everything just go to complete garbage. First i tried to plug the vim into a monitor, no image. I tried to plug to a tv or another monitor, there is an image that appear a few second, the first androidtv with CE logo, then it just glitch and nothing happend, no video output.
I tried everything to boot to the sd card, and none of the very few entry in the doc are working : keep pressing the power button until it enter whatever-mode ; press several time the function button ; or press power, plug the cable, press reboot one time, wait two second and release power = nothing is working.
Funnily i arrive, i don’t know how, to enter the recovery mode of the ATV, but as i didn’t know what are the key to navigate i press the function button that appear to be an enter key. A shame but i don’t know if the other recovery option would have helped whatsoever.

Which image you have tested?

Have you checked the latest Ubuntu server image ?

https://dl.khadas.com/Firmware/VIM3/Ubuntu/EMMC/VIM3_Ubuntu-server-focal_Linux-4.9_arm64_EMMC_V1.0.7-210625.img.xz

Check this docs to upgrade the firmware with USB cable.

For the image with 5.x kernel we call it mainline kernel image, which with latest kernel but some functions can not work properly. So we suggest you to use the image with 4.9 kernel.

And for WOL function, only works on 4.9 kernel, please check the docs to setup the WOL.

1 Like

“Which image you have tested?”
What was available, it’s not 50 iso.

"Have you checked the latest Ubuntu server image ?
Check this docs to upgrade the firmware with USB cable.

For the image with 5.x kernel we call it mainline kernel image, which with latest kernel but some functions can not work properly. So we suggest you to use the image with 4.9 kernel.

And for WOL function, only works on 4.9 kernel, please check the docs to setup the WOL."

I already said i get a shadow of stability with manjaro, and that i am too tired to make it work now. This device made me lost hours with problems and incompatibility, all i want now it get rid of it. This is great to point a new image that is probably fixing problems, but for me it’s too late.

As for the wol i describe its behavior in details in my previous post, and with ubuntu 4.9 so i suppose it’s your kernel.

So again you post a message to tell me exactly what i do not want. I want to know how to boot krescue when android tv is enable, because right now it’s impossible. Then i flash coreelec… and i really hope i won’t have another problem with it.

@atohmdiy I didn’t read your original post, tl;dr,
but going by your thread title, I presume you are having issues with krescue not booting from android TV on eMMC

the issue this isn’t working is because the uboot that the android TV image uses is not compliant with the khadas hardware, by default the standard bootloader on Normal Android or The standard bootloader issued with mainline kernel should allow the SoC to enter external boot mode.

I’m sorry if this is little too much for you to understand, but you cannot blame it on khadas for it, afak the TV image is not made by khadas themselves.

I will see if I can make a beginner guide to try to help people know what works or not in current states.
I’m also a general SBC user like you, because there are so many things that cannot be listed or sometimes informed to by reviewers. so I understand and accept your plight :slightly_smiling_face:

best of luck,
cheers

Yes it’s obvious the bootloader used in atv is not compatible with krescue. But i still blame khadas, they push this image into their official repo so it’s their fault, and there is no documentation anywhere. Not hard to put a popup with some explanation in krescue saying “be aware the bootloader in this image is not a compatible with the khadas bootloader, you wouldn’t be able to start krescue after flashing this image”.

That’s exactly the problem with the sbc world. Buggy hardware, buggy software, over-complicated thing and manufacturer with no respect of their customer, that cannot write a correct documentation. If you want info you need to dig the forums and it’s boring and time consuming.

And as i want to say more i will say this. When you build a platform you need some standard to make everything work together. Ask this for nintendo for exemple with their switch, there is an api, you cannot do anything you want, if you make a game for this platform you need to be compatible to the standard. This is not normal to have different behavior with the bootlader like that. The procedure to enter some kind of force boot mode, like explain in the doc, should be the same for all image in the krescue repo, and frankly i don’t understand these history of mainline uboot and i don’t really want to, for me it’s a waste of time.

“by default the standard bootloader on Normal Android or The standard bootloader issued with mainline kernel should allow the SoC to enter external boot mode”

Again it doesn’t make much sense to me, but i suppose there is a way to enter this “external boot mode” and boot krescue ?
Thank you anyway for your answer, and sorry if i appear offensive, i am just tired of spend so much times to maker this thing to work.

1 Like

no, it won’t work in non standard distros

I thought I read something about installing Krescue to SPI flash to get around some of this, but so far I have not found the reference, though SPI Krescue images exist.

@hyphop Please help to check.

plz read this doc before !

yes those exist, but mainline uboot won’t allow for the android/androidTV on the eMMC to boot iirc, however if you need to use linux (both BSP and Mainline kernel images), it will work :slightly_smiling_face:

Thank you but i red it a long time ago. As i said earlier no solution in the doc is not working, and it’s incomplete at best…

ok i will check it again ! and i can comment this situation later !

You don’t check anything. Second time i post here, no one ever gave me a solution to anything, only cryptic two sentence answer.
I will just sell the damn thing, and never buy khadas again, keep your crap.

  1. i have write solution before > https://dl.khadas.com/Firmware/Krescue/system/README-rescue-boot.txt
  2. any time if we have UART and uboot console store init 3 fully erase emmc > U-Boot Usage Guide | Khadas Documentation

You guys are troll really.
1 I saw your wiki entry a thousand times, and for the thousand times your procedure is NOT WORKING. Damn…

This

  • unplug usb cable
  • insert SD card with Krescue
  • press and hold POWER_KEY
  • plug usb cable and wait LED blinking after u can unpress POWER_KEY
  • ok Krescye system bootup from SD
    IS NOT WORKING. You get it now ?

2 Don’t even know what you are talking about really…
Your one sentence short answer seems to indicate i need to enter the vim in some kind of special mode with a serial connection, to enter a command to erase the emmc. Don’t know how to do that, write again your wiki it’s not understandable, i don’t even know what this page you linked talk about.

@atohmdiy you are correct, you need a serial console/connection, there is a guide to running a serial terminal from the uboot on the wiki

have you used a serial debugging tool ? or even perhaps any random microcontroller that most likely uses UART for programming like an Arduino Uno? you could make use of it to do the required here

i have check this situation today
last krescue + https://dl.khadas.com/Firmware/Krescue/images/VIM3-Android-TV-VIM3_USER_ATV-v3.0-20200803.raw.img.xz

  1. Krescue booting without additional preparations
  2. but cant start and have reboot loop (i will try fix this situation - missed something with latest kernel)

at this moment have other solutions

  1. any time we can use amlogic burn software and clean emmc - Upgrade Via a USB-C Cable | Khadas Documentation
  2. uboot console - check prev messages U-Boot Usage Guide | Khadas Documentation

in any case tnx for testing …

BTW: https://dl.khadas.com/Firmware/VIM3/Ubuntu/SD_USB/VIM3_Ubuntu-server-focal_Linux-4.9_arm64_SD-USB_V1.0.7-210625.img.xz works from sd

https://dl.khadas.com/Firmware/VIM3/Ubuntu/SD_USB/VIM3_Ubuntu-server-focal_Linux-5.12_arm64_SD-USB_V1.0.7-210625.img.xz same as krescue fail

its mainline kernel + old vendor uboot problem - we try to find some solution

I 2 have the same problem… How come i always read others have the same problem as i have … after i get Installed the android TV to EMMC. Now krescue form SD does not work… stuck in reboot neigther does ububtu from SD.
BTW my computer does not detect the VIM3 when connected through USB. The usb-burning tool also has trouble parsing the images…
so HELP please give me a workable solution!!

HS booted with the

cleared the bootloader using the CLI mode on Erase eMMC Storage | Khadas Documentation
and i was able to boot krescue.