Cannot boot after upgrading Ubuntu ROM

Please help. After sudo “dd if=Armbian…” copy ubuntu 16.04 to SD card.Insert SD card in the the slote and power on the Khadas VIM then, press Function key, seem waiting forever, no boot of Ubuntu except 4 small circles.

Hi, we need more information to help you locate your issue.

Please describe the following things asap:

  • Step by step operations with detailed description
  • would be better to take a photo with the monitor
  • tell us which version ROM you installed?
  • other needed info

thank you for prompt reply. THe step as follows

  1. format SD card to fat32 format( mine is 64GB) using : sudo gparted
    2)copy ubuntu img to SD card using : sudo dd if=Amrbian_5.24_Amlog-s905x_Ubuntu_xenial_3.14.29_20161223.img of=/dev/sdc bs=4M && sync
  2. insert SD card to Khadas vim. After power on,press function key for a while and wait and wait.
    For the picture(s) will be sent later.(sorry)
    Thank you once again for your patience.

Did you notice the topic to upgrade Ubuntu on SD card?
For you case, you might need take a note following:

  • You need burn VIM’s bootloader into the SD card
  • would be better erase the EMMC first

And there is a ubuntu ROM for EMMC, you can have a try.

Thanks will try install bootloader into SD card snd revert. In case erasing EMMC , can we install Android back later ?

Yes, you can install Android back. and you may be interested in:

Further our discussion above. I’d like to report to you that regardless of how many times I have erase and rewrite the bootloader and ubuntu image file both via linux command and Windows app(image write), I can not boot Ubuntu on my Khadas VIM board.
Could you recomment me for easy solution like downloading a complete ISO or IMG file that once write to SD card and automaticly bootable ?
This will help promote the sell of the boards too if it is easy to use.
ps. if you have an image or iso file that once write to SD card and it can be multiboot,it will be perfect.

Hi, for your case, recommend to upgrade the Ubuntu on eMMC ROM, more details check here.

Thank you but this is the ROM that am now using.
Furthermore it can not play vdo smoothly.
Any better recomments ?

Is it mean that your VIM can boot with the Ubuntu ROM on eMMC now?

No sir, I am exhausted and am giving up trying to boot into Ubuntu. Wishing one day in the future, maybe someone find out the solution and post to this community.

Did you notice the post #6 above? It’s just same approach to upgrade Ubuntu ROM on eMMC with upgrading Android ROM.

Guowa, Did you have successfully tried to boot Ubuntu from SD card on Khadas VIM by youself ? If yes, please eraborate
the procecure step by step to newbie like me to follow your footstep.

This morning I tried to write bootloader to SD card as per your manual. Turn9ng on piwer and long press Function key and release. All I can see just 4 small cicles on the monitor and keeping on cicleing for endless time.

Which bootloader version did you use?

PS: the DDR timings is built-in on bootloader.

Breakthrough at last ! (at least at the time neing). I can boot into LibreELEC linux which has nothing but kodi jarvis.
It’s not stable. Have to unpluge all the time to restart unless will be stucked at thev"4 cicling circles" again.
My untimate aim is booting for Ubuntu. So will retry and revert.