Can you help me with an nvme issue?

Which system do you use? Android, Ubuntu, OOWOW or others?


Which version of system do you use? Please provide the version of the system here:

  • Tested with Android 11 image from OOWOW (most recent)
  • Tested with Android 11 image built from source code (per Khadas instructions)

Please describe your issue below:

Hello, I have a 1TB nvme ssd I would like to use with my VIM4.

My current hardware:

  • vim4
  • (old) M2X Extention
  • Kingston NV2 1TB M.2 2280 NVMe
  • LTE Modem (works!)

Note, the M2X is connected with the ribbon cable, the VIN to VIN cable is disconnected.

I have tried adding a single partition and formatting. I’ve tried with both ext4 and exFAT (windows). Neither filesystem seems to be recognized by the android system. If I search the dmesg via adb shell dmesg but do not see any messages pertaining to the nvme.

Is the VIN cable required here? My understanding is it is only required to power the VIM4 via POE. Is it a compatibility issue with the NVME itself?

Any ideas are welcome. Thank you!

Hello @rpkish

@william.lin will help you later.

@rpkish Firstly, it is necessary to format this SSD on the windows computer and recognize it on the windows, making it readable and writable. Then insert VIM4 again and see if the Files application can automatically recognize this SSD drive? If not, please provide the following feedback:

ls -l dev/nvme*

Hi @goenjoy,

I have formatted the nvme under Windows, and here is the result of the command you suggested:

$ adb shell
VIM4:/ $ ls -l /dev/nvme
ls: /dev/nvme: No such file or directory

I also checked dmesg, it seems like the kernel does not see the device?

$ adb shell dmesg | grep nvme
[ 0.000000] <0>[ 0.000000@0] a5400000 - c0400000, 442368 KB, linux,nvme_ssd

So I tried another nvme, a cheap one from my raspberry pi, funny enough, that one worked:

$ adb shell dmesg | grep nvme
[ 0.000000] <0>[ 0.000000@0] a5400000 - c0400000, 442368 KB, linux,nvme_ssd
[ 0.963801] <6>[ 0.963801@1] nvme nvme0: pci function 0000:01:00.0
[ 0.964044] <6>[ 0.964044@3] nvme 0000:01:00.0: enabling device (0000 -> 0002)
[ 1.072845] <6>[ 1.072845@3] nvme nvme0: Shutdown timeout set to 8 seconds
[ 1.100824] <6>[ 1.100824@3] nvme nvme0: allocated 64 MiB host memory buffer.
[ 1.259514] <6>[ 1.259514@3] nvme nvme0: 8/0/0 default/read/poll queues
[ 1.270490] <6>[ 1.270490@3] nvme0n1: p1 p2

So this case is closed, thank you for helping me with this and all of my other questions. :slight_smile: