Can not get VIM3 into upgrade mode

Yes but not luck with that… So return is the only option and with this pandemic situation it’s going to take ages.

@Spikerguy Is serial mode useless ?

Uboot doesn’t accept any key stroke to let me enter into uboot cli. If that was possible I would have done that long back.

@Spikerguy At present, there seems to be no good solution, so I have to send it back for repair.


@Spikerguy please see the return shipping details (

1 Like

vim 3 can’t get into upgrade mode. I have manjaro on my sd card and I am trying to boot from this disk.

Before, I flashed android with USB Tool tool. While doing this flashing, pressing the middle button 3 times enters the boost mode. But when I plug in the sd card and do the same thing, the android always opens. Does not boot to sd card.

Please long press POWER key to boot from SD card.

He did not notice. same again. I tried it maybe 50 times.
But when you connect it to the computer and press the middle button 3 times on the USB TOOL tool, it immediately changes the mode.

Hi, is it possible to replace the SD-card? preferably SanDisk or Samsung and check again.

Have you previously loaded into the SD-card using this algorithm?

I used 3 different sd cards. (toshiba, samsung and panasonic)

I’ve done these operations over and over again. It’s been 2 months since I bought my vim3. And I’ve flashed too many times. Based on user experience I say
“USB TOOL external upgrade mode is not stable.”

3 blue lights are on and nothing else is happening. The system continues to boot. Before, I was overcoming this without knowing how. But now I haven’t been able to, although I have tried many times. Maybe I’m incompetent.

Please clarify, does the Android system boot from eMMC internal memory without any problems?

emmc also has android. and it works smoothly. Android constantly boots up because it can’t go into upgrade mode anyway.

Look from Android, sd slot reads sd cards?

yes it recognizes all the cards. And it gives a fix warning because it is partitioned. But he sees the cards without any trouble.

Have you updated Android, maybe there is a compatibility problem?

Hello @fkaraokur

What you realy want to do ? Upgrade the firmware from eMMC or just boot firmware from the SD card?

I think he cannot switch from one system to another sd / eMMC and calls it bad “update mode”

emmc also has android. It works smoothly. v200917

I have a sd card. 3 units. each has a different system. one is manjaro. like the other krescu. So I have bootable sd cards.

I powered the system. The blue light of my Vim3 is on and waiting. The blue light is constantly on. Now I want to open it in upgrade mode. I pressed Power for two seconds. then, within 2 seconds, I pressed the middle button(3). Blue light flashes 3 times. And the result is always disappointment.

so it doesn’t open from my sd card. My problem is actually very simple.

but interestingly, I connect it to my computer with a type c cable. I open the USB tool tool. When I do the same, it is detected by the software and it goes into upgrade mode.

If the blue light on, it means that the WOL function is enabled, you need to press POWER key to bootup. You can bootup to androd and disable this feature.
Check: Setting->More Settings->WOL, to disable WOL and reboot.

You can’t boot from SD card by pressing FUNC key 3 times!
You need to LONG PRESS the POWER KEY to boot from SD card.

  • Power on VIM3.
  • Long press the Power key without releasing it.
  • Short press the ‘Reset’ key and release it.
  • Count to 10 seconds and release the ‘Power’ key to enter into upgrade mode

Of course you can enter upgrade mode.

I find that when you look at the screen while you are doing this, and you keep the finger on the power button till the the second time the boot logo appears upon pressing the reset button is the most likely way you get into the Upgrade mode :slightly_smiling_face:

Its all precise timing, overshoot or undershoot the timing and you are just rebooting the device…
Time it just right and it latches correctly.