Bring the build to libreelec community


#41

@kszaq
Does this set of u-boot commands activate multiboot on any u-boot ? Here is your s905_autoscript.src

I don’t have anymore Android on eMMC so i can’t do this
settings - about - update&backup - updateLocale-select - aml_autoscript.zip - update

I flashed Ubuntu server image from khadas (as android u-boot does not have ext4 boot support), but I don’t know how to activate back that multiboot, to boot your LibreELEC image which is already on microSD and working fine for weeks.


#42

@kszaq Thanks very much for your build.

Today I finally got LibreELEC 8 running on my Vim Pro.

The tricky part was how to enter u-boot. I need to use an UART cable, Android build “Vim_Marshmallow_Root_170303”, when rebooting the board, press any key to enter the u-boot.

Then I followed the instructions from your thread here: https://forum.libreelec.tv/thread/2156-8-0-2e-libreelec-8-0-for-s905-s905x/?pageNo=1

Finally, run “run update” to get LibreELEC booted.


#43

Anyone tried to install kszaqs libreelec 8.1.x release on vim pro? I tried all methods to install it, but i can not.


#44

Did you also included the right device tree?


#45

Yes I did use the correct device tree.


#46

Then I have no idea. I never tried the new versions.


#47

Hi. I checked out the launch of your latest build LE for VIM Pro. When using dtb c your site, LE does not start. I replaced “dtb.img” on my option, it’s boot and all running (kvim.dtb). This is the source code of dts , which I use to build working file. Maybe it will help you to find the cause of the failure in your file for the new version (8.2) to run on the VIM1.

To ALL
To use the latest build Kszaq (8.2) you can use this version of the dtb file. I’m with him everything works on the IOS and Android-6.


#48

Thanks very much @balbes150!

Was there any problem or it’s suitable for daily use?


#49

I checked only the common run, work wired, work audio via BT, I see the WiFi network, tried playing a simple video. Installing to internal memory I haven’t checked (I have installed in eMMC Armbian with KODI that plays a fullscreen video).


#50

Hi @balbes150, thanks for the prompt reply.

The current version running on my VIM1 Pro is “8.0.2e (2017-07-04)”, it works well for the most tasks.

However, there are glitches when navigating the UI, especially navigate into Album list or Movie list.

Is it possible to use upgrade over “SMB share” from Kszaq version to yours?


#51

I tried yesterday to update for Kszaq-s LE 8.2 with his device tree, and now my Vim does not boot, my device is stop on khadas logo. How can I fix this? Usb burning tool does not see my device, I can not erease EMMC with buttons on the Vim, and I can not boot into upgrade mode with keys mode…


#52

I doubt that the possible transition to another version using the tar file. This is a different version of the kernel 32 or 64 bit. You can burn my image to an external drive, update multiboot (it is universal and can work with all the LE and Linux images, including images Kszaq), and try my way with external media. In this mode you can use both versions of the LE in parallel , as needed.

You can use contact closure “M” of the register, in order to start the process of firmware with a PC.


#53

Thank you, with this method my VIM is working again. :wink: I installed LE 8.1.2 with your dtb file and it is working fine from external drive, but when I am using the “installtointernal” command from SSH, my device stop booting, just show the Khadas logo.


#54

Thank you, I updated device tree for KVIM comparing your one to original. I tested a fresh install and it boots properly. I also added a note on LE forum how to easily boot to LE for the first time: https://forum.libreelec.tv/thread/5556-howto-faq-install-community-builds-on-s905-s905x-s912-device/


#55

Thanks!

I’m now using your device tree with the Kszaq’s latest build 8.1.2 and it works. Upgraded using SMB.


#56

It may be worth it to transfer the file arch/arm64/boot/dts/kvim.dts (linux-amlogic-le) to a shared directory arch/arm64/boot/dts/amlogic/kvim.dts ? Then it can be used to build multi-dtb.


#57

Not working so great after a reboot. Now I got no stable WiFi connection :sweat_smile:


#58

Hi @vrabac,

I’ve just had this issue. It was with an SDSC (2 GB) card. Then, I’ve tried with an SDHC (4 GB) card, and the issue was gone. So either all SDSC cards or some SD cards (still to be characterized) are not supported. @Gouwa, please update Upgrade Introductions: Via a TF Burning Card and Create Burning Card Via Command Line accordingly.


#59

Thanks for the feedback, @numbqq we will double check first then update the docs.

Thanks!