Bricked my device


#1

Hi

So, I tried to install the dtb “meson-gxl-s905x-khadas-vim.dtb” from upstream linux, and the device since the reboot, is always on a reset cycle. I am (now) aware I should had understood better what the DTBs are and how to use them, but anyway, I messed it up.
Here’s the kermit log I get:
https://pastebin.com/c3WFmErX
It’s the same output every time. It resets when it says “Resetting CPU …” and then it’s the same all over again. I cannot enter any command from kermit.

Is my device dead? Or can it be fixed?
Thanks


#2

You can refer to Howto Boot Into Upgrade Mode and flash your VIM by MRegister Mode.
Have a try. Thanks.


#3

Thanks! I had tried it but it turns out I didn’t have a conductive enough wire x)

Anyway, I downloaded “VIM_Nougat_170901” firmware, I created a bootable sd card, added the update.img plus a aml_sdc_burn.ini and started burning. It completed successfully but when I started the device again, it wouldn’t start.
The output of the burning procedure is this:
https://pastebin.com/Jr9D8vv6
The output of booting procedure is this:
https://pastebin.com/7WnXDtvP

:confused:


#5

Did you want to create a burnning sd card and not a bootable sd card?
You need to download the Vim_Uboot_Nougat_170512 to create a burnning sd card for VIM_Nougat_170901 firmware.
Thanks.


#6

I wanted (and still want) to create a bootable card.
The only way I succeed so far to install firmware on the device is with Windows OS with burning through USB.
USB booting is working. I used an image from balbes150 and it successfully boots from it.
But SD, no luck…

Anyway, I’ll come back with more questions maybe in another thread since this thread was solely for realizing if I messed up my device…

Thanks for your responses