Boot With SD Card keeps rebooting

  • Power on with power adaptor, TYPE C cable.
    I actually tried multiple OS with SD-USB support (NOT EMMC). However, whenever I tried to boot VIM3 with my successfully flashed SD card, VIM3 seems to keep rebooting after the following line:

    Scanning for Btfrs filesystems
    [ 11.316…] vout: aml_tvout_mode_work: monitor_timeout

    VIM3 NEVER boots into the OS on SD card.

  • Power on by connecting to Host PC via TYPE C cable. This will lead VIM3 to boot into EMMC’s OS all the time.

Did anybody meet this issue? I wonder if VIM3 is still in the MaskROM mode ?? If yes, how to jump out of this upgrade mode? If not, what are the differences between using the power adaptor and using host PC to power on VIM3??


How you supply the power?

First never power Vim3 with Pc USB connection as it can only provide 5V 0.5Amp which is not enough to power on all the IO example (USB,SD) in some cases.

This shows that it is reaching till kernel level so must bee something wrong with the kernel.
Can you share which Image have you flashed on sd card and also which OS is running from EMMC?

in real its not almost true :wink: 0.5A its minimal guaranty by standarts
and real current depend of used usb ports

for example i can power any VIM boards from my laptop without any problems

biggest problem its poor quality of usb cables !!!
plz use only hi quality usb cables - short length (15-30cm) preferred

PS: aml-burn-tool and krescue can use usb cable for flashing and powering at same time

PSS: sure real loaded system with attached usb devices can require 2A and more … which common usb port cant provide

1 Like
➜  VIM3_Ubuntu burn-tool -b VIM3 -i ./VIM3_Ubuntu-xfce-bionic_Linux-4.9_arm64_EMMC_V20191231.img 
Try to burn Amlogic image...
Burning image './VIM3_Ubuntu-xfce-bionic_Linux-4.9_arm64_EMMC_V20191231.img' for 'VIM3' to eMMC...
Unpacking image [OK]
Initializing ddr ........[OK]
Running u-boot ........[OK]
Create partitions [OK]
Writing device tree [OK]
Writing bootloader [OK]
Wiping  data partition [OK]
Wiping  cache partition [OK]
Writing logo partition [OK]
Writing rootfs partition [OK]
Resetting board [OK]
Time elapsed: 8 minute(s).

Any further suggestions?

Did you try to enable multiboot ?

You will have to enable multiboot for the device to boot os from sd card.
Steps how to enable multi boot.

I am not really sure if ubuntu on emmc have multi boot function.

Have you managed to solve your reboot problem? I had a similar problem which was being caused by the usb cable I was using. I agree with hyphop on this.

Does it work now, I believe the problem is caused due to insufficient power delivery, what were the symptoms shown by the board any output, or does it directly boot into eMMC ?