Black screen after boot

Hi guys,
I’ve already made it… but don’t work for me… I’ve made a try with burning card by win32diskimager for this reason.

That I’ve saw, if I wait about ~10 min, it appears the beginning sequences of booting ubuntu (my ancient rom) and disapear right now… and appear again 10 min later… and again and again… It’s very strange.

@Cimmarron: You say long press the power button… how much time? ~15s before short press reset key (like Gouwa recommended?)


Just in this secuence,
Vin complety turn of.
I long press power button without release
I plug in the usb cable to 5v adapter, then the Vim is tuning on.
Short press Reset key
count 3 seconds
and finaly I relaased the power button.

after that, an android screen appears and upgrade. I tested with diferents images,
good luck

Vin complety turn of.
I long press power button and funcion button without release.
I plug in the usb cable to 5v adapter, then the Vim is tuning on.
In the screen there is a VIM logo, after 10 second more or less the vin logo disapears. Release the buttons, The Emcc is clear.

15 seconds is for EMMC erasing :wink:

And 3 seconds is enough for VIM to enter into upgrade mode.

Do you know how to use USB-to-TTL serial tools, if yes, things would be more easy, as you can also try Serial Mode of following approach:

How to boot into upgrade mode

I guess you didn’t got EMMC erased yet, as everything on EMMC will be wiped out after erasing, so your VIM can’t display anything on monitor then.

And you need make sure that you have crated the bootable SD card with the ROM image.

Good luck.

Hi everybody,
to sum up that I’ve made:

  • Prepare a new sd card (32gb/class 10) with the khadas tool.
    there is a printscreen of my card:

  • Flash the Emmc: Vin complety turn of, I long press power button and funcion button without release, I plug in the usb cable to 5v adapter and wait about 15s (on my monitor I see the green screen, after the logo VIM appears and disappear).

  • I turn of the box, plug my SDcard, turn on the box with power button pressed, wait during 3s (with power button pressed), release the button…

I wait a little bit but the bugdroid logo don’t appear…
What is wrong for me??
I’m a little bit discouraged


Vin off completely
Press and hold power button,
still holding power button, press the reset button for 1 second(release reset key after 1 second), wait three seconds and release power button. That should enter upgrade mode.

From Khadas docs…
Long press Power key without release
Short press Reset key and release
Count 2-3 seconds and release the Power key to enter into upgrade mode.
If everything goes fine, now your display/monitor should display like this:"

1 Like

I’ve already made this and nothing happen.

Hi Gouwa, I’ve try with my USB-to-TTL tools under Ubuntu but when I start the command “kermit”, My box isn’t detected…

BTW, I noticed that my VIM board did not always reliably entered upgrade mode. However holding the power button pressed and inserting the USB cable, then releasing the button after the device appears always did the trick.

It happens when you plug youre box to the pc or to the dc adapter?

You can check step by step following Setup Serial Debugging Tool
You need to take notice that both Rx and Tx are connected correctly .

One day windows no more recognize my VIM, them I cant use USB_burning_tool. the way to upgrade via sdcard.
But today I think, why not test with my old win7, it is in other partition in may PC.
I install USB_burning_tool in win7, plug the vim with usb cable and voila. it works.

fidoboulettes test it, may be you can…

Hi Cimmarron,
It was a great idea… I installed a new version of W7 in a old PC, re-install the burning tool, apply the procedure to be in upgrade mode (
Long press Power key without release
Short press Reset key and release
Count 2-3 seconds and release the Power key to enter into upgrade mode

But unfortunately, My box isn’t recognise by windows…

Have you tried this:

  1. Disconnect the VIM from the PC and any power supply. Make sure there is no SD card inserted.
  2. Hold the power button, and plug the VIM to the PC USB socket using the USB-C cable supplied.
  3. Check the device manager to see whether you have the device recognised by windows, and release the button when it does.

This always work in my setup.

Hi, it seems that your problem exist a long time, and still didn’t got any resolution.

As Jose(jcalvarez) said above, you can also follow his steps and have a try.

If your problem still don’t got resolved, maybe you can have try with MRegistor Mode method in this instructions, as the MRegister Mode will work always.

Good luck!

Hi fidoboulettes, you don´t need put the VIM in upgrade mode when conect it in the PC. only start the burning tool first and before Hold the power button plug the vim with the USB-C cable, them windows recognise the box and installs the driver.

Thanks jcalvarez, that is the way: Hold the power button when plug the vim to the PC.

@Cimmarron you are welcome, glad you got it working :thumbsup:

Hi everybody,
the problem is finally solved after the MRegistor Mode using… What I’ve do:

1: Start the USB upgrade tool
2: short-circuit the pad of M mode with a little flat screwdriver (It’s the most difficult because it’s very little)
3: plug the box to my PC and Tadaaaam, my box is recognised by windows
4: burn the Emcc withe the last android rom

Thanks a lot for all for the help and I change the status of this post. (and sorry again for my poor english)


3 posts were merged into an existing topic: Voices from user confused

Congratulaions fidoboulettes.
Finally you solved after some days trying. Great