Best way to add Google Play to AOSP

What would be the best way to add the google play store and other legit google apps to the AOSP 64bit build of Android 11

I don’t mind Open GApps but would prefer the full version so as to be sure I don’t get locked out of anything.

My end goal is to run the Google assistant hands free and for google maps GPS use hands free.



Hi, maybe this will help you somehow, since the built-in services from Google already come from Amlogic in the firmware, but Amlogic has not done anything for Android 11 / 64bit at the moment. :man_shrugging:t3:

So far, only so …

They dont seem to have Open GApps for Andy 11 yet tho, only 10…

Are you saying that this AOSP build I am playing with will one day have full google apps built in?


1 Like

As a rule, Google services come with the Amlogic SDK, they are quite legal.The only question is when Amlogic will deign to publish, maybe they also have problems with Android 11.

Please take a look.

1 Like

I am fairly stuck on how to install NikGApps into the AOSP without TWRP in the mix…

Hello, yes, as a rule, they are sewn into the phone, for TV boxes they are already ready with the SDK, perhaps root access will help so that this can be done without the help of twrp. And try to ask the author of NikGApps, maybe he can tell.

1 Like

How do I Install open GApps using ADB?
Because I use ADB over wifi and Type C is needed for power so I will not be able to connect the board to PC through Type C otg.

And when I enter into recovery my device gets disconnected through wifi.
Is there any other way to install GApps??

@Parth_Prajapati you can connect the board to PC through Type C otg ,PC also can power the board and you can also use adb at the same time

I tried from SD Card but got an error of architecture mismatch.
I tried few other architectures as well but still getting the same error.
So, now I am trying to build the Gapps along with AOSP.

you can refer to this link

Hii @jasonl

Thanx for your help.
I got it working.