Audio Output Issue

Hello, I bought the VIM box two weeks ago so I am definitely a noob;

I would like to pose a problem: I have no audio output from the Khadas VIM box despite having tried different firmwares.
I connected the VIM via HDMI to two different TVs.
I tried: Marshmallow Root 160603, Nougat Root 170612, Khadas VIM SCV1-ATV and Dual OS Marshmallow Ubuntu via USB-C cable without success no audio output at all.
Please give me a chance or I must consider the VIM box as “defective”.


Hi, luxmo:
Did you try to use another HDMI cable?
Also , You can connect another box via HDMI to your TVs with the same HDMI cable.

Yes, I tried another HDMI cable and yes before Khadas VIM I connected a Raspberry pi3 with success.

  • An update, installing the last Ubuntu Mate firmware 170831 I got the audio output.
    What do you suggest??

If the Ubuntu ROM works, the Android ROM should be works with the same HDMI cable, can you kindly check again?


Here I am, it’s nice trying to fix the issue together.
Update #2 I tried Khadas VIM SCV2-ATV and the last Nougat 170901 (no root) with the same result:
I got Audio only over audio notifications and alarm clock,
setting the volume of the TV to the maximum the Multimedia volume seems to be too low yet (obviously it is set to the maximum).


Are you a developer or a normal user? Can you assist us to catch the print log to us for the issue-location?

And can you tell us the LCD/Monitor model you used?


Sorry but I’am a normal user but I would like to assist you, tell me how I can catch the print log.

I used two different models of TV:

  • Hisense H55M7000;
  • Blaupunkt 23/173G.

I would like to test the LibreELEC firmware too can I use the upgrade via Windows Burning Tool?


Not the same tool, check one of below guidance for the instructions:

Kindly test again with the LE ROM, and our guy will post a topic for the details steps to catch the print log tomorrow.

Good luck!

Well I tried several times to install LibreELEC via Windows PC guidance without success.

Update #3 Installing Nuogat (both root and unroot) with the following settings I got the audio output:

  • Audio Surround: AUTO
  • Dolby Sounds: RF
  • Digital Sounds: HDMI
  • DTS Sounds: 0.

others firmwares do not have these settings, do you think that I can reply this setting for Marshmallow or SCV2-ATV ?

Thanks for the update!(Still no idea and strange, all the Android ROM should be works fine in your case)

Yes, ATV ROM should be also works, you can take a try :wink:


I tried it but as I said before also ATV ROM doesn’t have this setting under the voice SOUND, so do you have an idea to change these parameters through a sort of command line?

Update # for your developers, there is a bug changing the language (i.e. italian) the system lags and the UI crashes.

Best regards