Armbian + KODI (Ubuntu\Debian) for SD & USB & eMMC

I decided to open a new topic since the old have accumulated a lot of obsolete data, which can confuse users.

To run all the images Armbian external drives, you must activate the multi-boot. One of the options is activated, you can read at this link.

Current Image Mate\XFCE+KODI (3.14.29) and Server


For those who already have images >20170628 you can only refresh the kodi package (download from the directory the deb on the website and install via “dpkg -i”

  1. The main feature of the use of Kodi in these images - all settings in the Kodi or Linux system you can run almost as usual in Linux. All configuration files and directories Kodi is available for direct editing.

  2. All images Armbian I removed the automatic download of wifi module at system startup. Because it leads to a hang on different models. You need to manually check

An example command to load module “dhd” or “wifi_dummy”

sudo modprobe dhd


sudo modprobe wifi_dummy

After verification of the selected module, if everything is working correctly, you can add it to the autorun list (add string name of the module in the file /etc/modules).

  1. To install Armbian in the internal memory, you must execute multiple commands. We strongly recommend TO RUN the INSTALLATION to create a full backup of the entire contents of the internal memory. This will allow you to return to the current state of the firmware at any time. To create a complete backup you need to execute commands.

su -
(enter passwd root)

The running tip backup script

After creating the backup, to install to internal memory (eMMC) of the command being executed
Pay attention, if you are sure that you will be able to solve possible problems from the installation of the internal memory (eMMC), do NOT PERFORM these commands.

su -
(enter passwd root)




I’ve tried this command sudo modprobe wifi_dummy, wifi enabled is checked but “wifi networks device not ready” is greyed out.

Now i checked on VIM (the original firmware in eMMC had Android-6). Off the wire local network. Launched VIM (using VIM for dtb). Load the module “wifi_dummy”. Set up the connection using NetworkManager. WiFi is connected and everything works. The browser goes online and all opens. Check the router settings and the correct start VIM with dtb.

There is nothing wrong with my router settings, wifi works fine with every device, works with Vim on Nougat and Marshmallow, works with official Ubuntu images.

I don’t know the cause of this, but it is driving me mad, i get “wifi networks device not ready” greyed out only after i run sudo modprobe wifi_dummy.

Read the instructions carefully.

After verification of the selected module, if everything is working correctly, you can add it to the autorun list (add string name of the module in the file /etc/modules).

I stll don’t understand what do i have to do, i still don’t have wifi working, i don’t even have an option to choose any wifi network.

I am not so skilled in Linux, so i need a detailed step by step instruction, i am not familiar enough with Linux filesystem, maybe i need a dtb for Vim to get it working?

I know i am starting to get boring, but i really don’t see a solution.


Version 20170705.
Changed algorithm activation HDMI. It now runs in two stages. Pay attention, changed the kernel image to be installed in the internal memory. In the image name removed KODI, as all desktop images by default with KODI.

Hi everyone

I do not have a USB keyboard, and when using putty for login from a windows pc I get access denied after entering the password
I used root and 1234
Is there any method I can use without buying a USB keyboard?


Update images 20170803.
Added support for remote control. To use it you need to add the correct file “remote.conf” in the /boot directory or /etc/amremote. By default, a part of the image includes several predefined files (in the /boot directory). To use it you need to rename one of the files in “remote.conf”. Additionally uploaded the site to the directory the deb package “amremote.deb” , which can be installed in the old system (do not download the whole image). After installing this package you need to run service “amlogic-remotecfg” and add (rename) the correct file 'remote.conf".


Updated the test images Armbian kernel 4.13.0-next-20170817+

Version update to 5.32 (20170820).

In connection with the transition to a new version of an Assembly environment, there are different bugs (which are not yet discovered).

Version 5.32_20170823 with kernel 4.9.26 (branch khadas ubuntu-4.9)

The images are in the directory “Test” on the website.

Work wired network, WiFi , BT. Pay attention, this version is not yet integrated with KODI HW.

1 Like

Wired network did not work. Wireless did not check.
The system (Armbian_5.32_S905X_S912_Debian_jessie_4.9.26_server_20170823.img.xz) was installed on a memory card.
Can anyone else check the operation of the wired network?

The server image is not checked, but Ubuntu-Mate the network is working, cloned a few rap at 300-800 MB, downloaded via the browser of several files at 200 MB. Problems with the wired network not found.

Образ сервера не проверял, но в Ubuntu-Mate сеть работает, клонировал пару реп по 300-800 Мб, скачал через браузер несколько файлов по 200 Мб. Проблем с проводной сетью не обнаружил.

Wired network does not work on all server test images? Or on some versions of the kernel there are working images?

Проводная сеть не работает на всех тестовых сборках? Или на каких-то версиях ядра (кроме 3.14.29) работает проводная сеть? Могу протестировать.

Я не проверяю каждый имидж по всем параметрам работы (на это нет времени). Я написал, что в последнем образе 4.9.26 с Ubuntu-Mate (ядро и модули у них общие для всех образов) проводная сеть проверена и точно работает.

1 Like

New image 20170828 kernel 4.12.9.

In this way there is support for USB on the platform S905X. You can run the system from SD cards and USB flash drives. Changed the activation system monitor, now it is built into the kernel itself. To change the screen resolution, you need to use standard tools from control monitor on a desktop. The resolution changes on the fly (directly on desktop). Not working yet WiFi. For s905x recommend to use a file meson-gxl-s905x-nexbox-a95x or meson-gxl-s905x-khadas-vim1.


Version Armbian 20170901 with kernel-next 4.13.0-rc7 with a working USB S905X.

1 Like