Armbian + KODI (Ubuntu\Debian) for SD & USB & eMMC

#324

I use the regular browser from your armbian image, and install media script with option System & MPV.

When I remove /etc/chromium-browser/default from media script, I can play 1080P video on youtube.

0 Likes

#325

Strange, I do not delete anything and everything works for me.

0 Likes

#326

I use regular Chromium arm64 build, those armhf builds from the script don’t use gpu, don’t know why.

Latest Armbian mali build works pretty nice, lima driver will probably be much better once it’s mature enough, but i am very pleased with this.

@balbes150, one thing i noticed yesterday, after updating initramfs, i did get sound back, but mpv lost acceleration in fullscreen, i don’t understand why?

0 Likes

#327

By the way if somebody need it - it is possible to boot directly from EXT4 root partition if it is formatted like that: mkfs.ext4 -O ^metadata_csum,^64bit
I was able to get rid of a separate /boot partition on odroid with
ext4load mmc 0:1 0x21800000 /boot/dtbs/meson8b_odroidc.dtb
ext4load mmc 0:1 0x21000000 /boot/uImage
and most likely it will fit VIMs too.

0 Likes

#328

Installed both
Armbian_5.73_Aml-s912_Ubuntu_bionic_next_5.0.0-rc4-next-20190130-g02495e76d-dirty.img
and
Armbian_5.75_Aml-s912_Ubuntu_bionic_default_4.20.5_20190211.img on VIM2
5.x - ethernet and wifi not working
4.x - no wifi - is it normal? Where I can get wifi module?

0 Likes

#329

Write in detail all steps that were done.

Wired network works in all images and on all Khadas models. WiFi works on VIM1 and VIM2 Basic with 4.20 kernel.
You love using your (invented by you) instructions, so I don’t know what you were doing and why it doesn’t work for you. I’m not psychic enough to guess what steps you’re taking.

0 Likes

#331

So there’s no Armbian with VIM2 Pro Wifi support not in kernel 5.x not in 4.x not in 3.x - right?

0 Likes

#332

@balbes150, i did run the script, marked all options available on the script, when the script was finished i did a reboot, then i fixed mali libraries through mc, after that i ran commands depmode and modprobe mali, last command was update-initramfs -v -c -k uname, all as root, then i rebooted again.

Before running this latest update-initramfs command, mpv was smooth as butter, but there was no sound, when sound returned, mpv lost acceleration, but i didn’t noticed it immediately.

Everything is solved now, everything works, thanks!

0 Likes

#333

In Armbian on the kernel 3.14 for all models VIM1\VIM2 has support for Wi-Fi.

0 Likes

#334

I tried “Armbian_5.44_S9xxx_Ubuntu_bionic_3.14.29_server_20180729.img” and wifi wasn’t working for me out-of-the-box. Maybe I had to additionally load some modules with hands but haven’t tried - that was it for me&Armbian. I took “VIMs_Ubuntu-xenial_Linux-3.14_mate_arm64_SD-USB_2018-05-31.img” and "it just works"© :man_shrugging:t3:

0 Likes

#335

Update images 5.76 20190226. The system now uses the new 5.0 kernel.

2 Likes

#336

Hi balbes,
thanks for your work (and sorry for my poor english).
I’ve actually a khadas vim 1 pro and install the 5.76 armbian server image with kernel 4.2.
Evething work except the wifi.
I didn’t understand how to activate it… is it possible or not?
And if not, wich version of armbian did i install?

Other question.
I also didn’t understand how to udpate an image when armbian is already installed (for ex, kernel 4.2 --> your last update 5.0)

Thanks a lot for your answers

0 Likes

#337
  1. For WiFi to work, check for firmware files. If not, you can copy them manually or install them from the DEB package.
  2. To upgrade the system to the latest kernel version, you can use packages from the DEB directory on the site. But if you have everything running on version 4.20, you can continue to use it.
1 Like

#338

:fu:
work well and after reboot armbian-config integrate the wifi part.
Thank a lot

0 Likes

#339

The new version of the image with the kernel 5.76 5-rc8.

Please note that the image files have replaced the previous versions of the files on the site.

The new kernel adds support for BT on VIM2 (S912), but the BT audio output does not work yet (the sound stutters, you need to change the settings and perhaps the firmware file).

1 Like

#340

New version 5.77.

Please owners of VIM1 Basic to check the work of BT and WiFi with this version.

0 Likes

#341

New version 5.77 (20190318). Updated kernel to 5.0.2. Fixed a bug with the overflow log.

1 Like

#342

I recently flashed Armbian 4.19 mali version on emmc, i didn’t do Android backup because i didn’t have any important data on it.

Now i want to return to Android, but the problem is that my pc doesn’t detect Vim1 usb connection anymore, so i can’t use usb burning tool.

Does this have something to do with newer u-boot that emmc is using now?

I need Android back because i decided to give Vim1 to my brother, i will use my voucher for another Vim.

0 Likes

#343

There are several options.

  1. Use M-register.
  2. Erase eMMC.
0 Likes

#344

I’ve tried both options already before, i did try to erase emmc, i was following instructions that are on khadas docs, don’t know why but when i rebooted, nothing was erased.

M-register didn’t work at first, i don’t know why, finally today i’ve managed to restore Android using this option.

0 Likes