Armbian + KODI (Ubuntu\Debian) for SD & USB & eMMC

and what’s more, it is harmful (to copy and rename DTB to dtb.img), then the automatic kernel update by standard apt tools will be broken.

Yeah. I’ll change it by my self and propose a file change. It should be done in the next 10 minutes.

Update: Done -

1 Like

@Z11ntal33r I test it with one USB3.0 hub && one USB3.0 U-disk && one SSD .
In SD_USB/VIM1_Ubuntu-server-bionic_Linux-5.3-rc4_arm64_SD-USB_V20190830.7z. I get the same error with you .
In VIM1_Ubuntu-xfce-bionic_Linux-4.9_arm64_EMMC_V20190830.7z.This error did not occur.

@balbes150 OK,I understand what you mean.

@balbes150 CE and Armbian are separate

I’m not sure why you are testing a meson-gxl device (VIM1) when I’ve a meson-g12 device (VIM3) and clearly point out that Amlogic has fixed this for Hardkernel and theirs Odroid-N2… Have you read some of the posts at Hardkernels forum regarding this issue?

I can confirm that the xHCL patch provided by Amlogic devs fixed the issue for me on my VIM3 as well. However, it’s not 100% perfectly fine as it seems that every first time I copy/move files from one ext. device to a new ext. device the transfer halts after some seconds before it continues (before the patch it triggered the IO error). Balbes150 has included the patch into his GH repository with the latest commit v20190918, so Armbian users with a meson-g12 won’t be affected of this further.

I suggest that you devs do some proper testing for meson-g12 devices with the latest vendor kernel - which I’ve not tested. I would recommend contacting Amlogic to hear from them as they made this patch for Hardkernel, which is also fixing the problem for VIM3.

Have a good weekend!

@Z11ntal33r Thank you pathch and you suggest . It’s very useful for us.

I don’t see any changes on the documentation page on the site. All systems are listed together.

Hello @Z11ntal33r

Yes, the vendor kernel also has this issue for VIM3. When I apply the patch, it works well. Thanks.

Added Armbian or LibreELEC dtb setup description.

I’ve made another pull request with some small changes and information regarding if another OS than Android, Armbian or LibreELEC has been installed to eMMC and the user want to install Armbian or LibreELEC to eMMC later. Feel free to do any changes!

The current version is not suitable. It creates more confusion. The manual says :

Step 2. Copy the Appropriate DTB File

But no copies in principle should not be.

Next, you will have to expand the list in these lines to list all systems that are not compatible with the old startup option.

All images except Armbian and LibreELEC Manjaro AltLinux ArchLinux etc


Armbian or LibreELEC Manjaro AltLinux ArchLinux etc

You will have to edit these lines again when new versions of OS systems are released ?

In addition, the corelec startup system is not compatible with other systems (which use universal multi-boot). I specifically draw the attention of users in all my topics on this feature. And on your page they are mentioned together, which again misleads users. I am tired of explaining to users why they are having various problems and what they are doing wrong because of such incorrect outdated instructions.


Hello Oleg,

Yes, the documentation is confused, one image to bootup many boards, and need to select correct dtbs.

For our current SD images, I don’t want to use one image to bootup all the VIM boards (VIM1/VIM2/VIM3) anymore. I want to create unique image for every board.

Although they have the same kernel, but still have some other parts are different, for example, the GPU mali blobs are not the same, you can’t use one image on both VIM1 and VIM3 with GPU worked, you have to setup it manually. And the u-boot is not the same, too.

I want to create the SD image like the eMMC one, with correct u-boot and DTB, and the users don’t need to edit the dtb files any more, they just need to write it to the SD card and activate the multi-boot. And they also can choose to boot completely from the SD card by erasing the eMMC.

And it is easier to write the image to eMMC, and it’s easier to upgrade the system by OTA.


1 Like

Hello. Could you please help me finding the latest version for Vim pro which has USB working. Tried plenty of versions. Need usb to use UZB zwave stick

With proper dtb setup, USB ports work in all images.

1 Like

I have edited both config files to use dtb for Khadas vim and when I boot, I cannot use usb keyboard, only ssh. lsusb shows me usb 2.0 and usb 3.0 hubs with no devices connected (keyboard and uzb stick are physically connected in the meantime). Both keyboard and stick are proven work in laptop and pi3b+

The VIM model (S905X) does not have USB 3.0. What model do you write about ? Which DTB do you use ? What is the full name of the image you are using ?


root@aml:~# lsusb
Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub


What combination of image/dtb should I use? Please advice

  1. What’s your model ?
  2. Have you tried to connect any other equipment to USB ports (USB flash drives, normal keyboard or mouse, etc.)?
  3. What firmware is in eMMC ?
  4. You have tried the “default” version (the " dev " version is a test version).
  1. Vim Pro 16gb Emmc
  2. Tried USB keyboard, mouse, pendrives
  3. Right now armbian is in emmc, installed on top of Android Nougat from Khadas
  4. Tried different versions, the current one is dev as mentioned in previous post

Should I flash latest Android Pie and try on top of it?
As far as I noticed, uboot is being updated during the installation to emmc.