Armbian + KODI (Ubuntu\Debian) for SD & USB & eMMC

Hi balbes150,

The image is Armbian_5.32_S9xxx_Ubuntu_xenial_4.13.0-next-20170905_mate.img, and the model is VIM2 Base (2GB/16GB).

I’ve tried meson-gxm-vega-s96.dtb, the usb is working on VIM2, and meson-gxm-q200.dtb is ok too. I just did something wrong. Thanks a lot!

1 Like

I’ve tried other ROMs on my VIM2 and they all had the distortion so its not balbes150’s ROMs. I’ll open a new thread to keep this one from going off track to get a solution.

Version update TEST kernel 4.13.0_next_20170907. Added support for sound for all models S905X and S912. Pay attention to one feature of the work of sound - on the desktop has to be set 1920x1080 resolution. Not clear to me yet why the sound only works in this screen resolution.

For some recent images to use these additions, you can only download the kernel and dtb files (deb packages are in the directory TEST\deb) to install in the existing system (don’t forget to update the file “dtb.img” to a new version).

In images enabled sound via HDMI to s912 (and s905x). Work sound tested on a Tronsmart Vega S96 (s912). Sound works through HDMI on test files from the image. Once again - you need to have 1920x1080 resolution (you can go into desktop settings in the tools menu and select directly in the working system needs a permit).

I am now testing obtained Khadas VIM2 MAX (Khadas thank you for the provided sample). :wink:

All images Armbian work.

With kernel “3.14.29” everything works (wired LAN, BT, sound) except WiFi and video hardware acceleration. Copy to manual dtb in this manner is not required, suitable in the internal memory (eMMC) from the regular Android firmware from the factory. I recorded the image on the USB flash drive, connect USB flash drive to VIM2, pressed and hold button “Function” (middle button), turn on the power supply, wait for 3-5 seconds and released the button. Activated multiboot USB flash drive and start Armbian. You can also activate the multi-boot via the standard update.

Tested the version-4.13.0-next (the last image 20170915). With the addition of dtb (gmx_q200) working wired network, sound, USB, display resolution can be switched from the working system on the fly (to change the resolution, rotate the screen). After running the MATE desktop, is still free more than 2GB of RAM. The next step is to install the radiator and fan (I will use the for VIM2 and check additional cooller).

1 Like


I can’t get Wifi working on the latest 3.14.29 Arbian images on Khadas VIM 8GB model. I’ve tried both the Jessie and Xenial images.
I’ve tried both “dhd” and “wifi_dummy” modules.
With both modules (dhd and wifi_dummy), network-manager shows the list of available connections and can successfully connect and authenticate to a network. But the network doesn’t work. DNS doesn’t work.

If I’ve read correctly, others have reported Wifi working on 3.14.29 Armbian.

I’ve tried stopping NetworkManager and configuring /etc/network/interfaces directly as described in this post.

I am not very experienced with Linux networking so I’ve probably missed something.
Would appreciate help debugging. My dmesg is here -
I noticed the line “Error getting the SSID”

I’m wondering if its an issue with the DTB? I have the Vim model with 2GB RAM and 8GB eMMC (not the Pro version which has 16GB). The table on the product page shows that the 8GB model has AP6212 wifi instead of AP6255 in the Pro.
Can anyone recommend the right DTB to use with the 8GB non-Pro version of the VIM? I’ve tried the kvim.dtb and gxl_p212_2g.dtb in the dtb folder on the boot partition.


I’ve also got a question about hardware acceleration in the Mate/Xfce desktop and Chromium browser, which I’ve started a new topic for:

I remember that this problem has been discussed before and if I’m not mistaken, there was a problem with the router (after resetting the anchor Wi-Fi on the router, the network work).

Thanks for your reply.
I have searched and could not find the discussion you mentioned.
Do you have any advice about which router settings might be causing the problem?
I have tried resetting the router, tried both modules, tried installing to eMMC and still can’t make the internal Broadcom chip work.
I’ve tried a USB wifi adapter which worked.

Alas, I can’t remember the topic where it was written and I have no model VIM (2\8) to check the operation of the Wi-Fi. Perhaps the owners of this model will write how they work.

Hello Balbes150!
Wonderful work : also tested your build (1509) : works as you described (VIM2 MAX).
Monitoring the cpu is a pleasure to see : optimizations and efficiency.
Almost usable (wifi, remote) : video is sluggish. KODI has a hard time to display. Video stutters.
I’m aware of the video driver problem (ARM policy, not AmLogic).
Are there any plans to circumvent this show stopper?
Thks a lot!

There are plans, but when it’s decided, I don’t know.

Update test image 4.14.0-rc1-next-20170922.


Burned latest 4.14. rc1 image, it shows khadas logo, and stays like this forever, sd card image.

I can’t figure it out why it won’t boot, am i the only one who is unlucky with your images, always having problem with them.

Tried to download the same image 2 times, always same result, it shows only khadas logo.

You have added the correct file “dtb.img” to the root FAT partition ?

Thanks for help, i didn’t fo that, where to download dtb.img for Vim?

It is not necessary to download. All the files are there in the image. Open the directory /dtb and copy it from file “kvim.dtb” in the / (root FAT partition) and rename it to “dtb.img”.

kernel 3.14
/boot/kvim.dtb -> /dtb.img


kernel 4.x
/boot/meson-gxl-s905x-khadas-vim.dts -> /dtb.img

1 Like

I have succeeded to run it, next issue is wifi, when i run sudo modprobe wifi_dummy, i get the message "modprobe: FATAL: Module wifi_dummy not found in directory /lib/modules/4.14 .0.-rc1-next-20170922-amlogics905x.

Thanks balbes for helping, i am a noob when it comes to Linux.

I see you can’t view cpu temperatures with armbianmonitor -m, it shows cpu loads and stuff, is there a way to monitor it?

Test image kernel 4.1x - not meant for home usage. Use version with kernel 3.14 and 4.9.

Image update Armbian 3.14.29_20171012.
Added some scripts for fan control and install the firmware for the VIM2.
To enable fan control, you need to uncomment the line in /etc/rc.local

Image update 5.34 Armbian 3.14.29_20171020.

In the Test directory added images kernel 4.9.40