Armbian + KODI (Ubuntu\Debian) for SD & USB & eMMC

@balbes150, your work is awesome. Is this possible to activate GPIO to use with RPi compatible hardware? I am trying to make Razberry GPIO card work

Write in more detail what you mean.

nevermind. i burned Razberry card as far as I understand

@balbes150 do your latest images have at least Kernel 5.0.8 and do they have full WiFi and BlueTooth Support for Khadas VIM 2 MAX ?
I’ve had issues with WiFi and Bluetooth in the past and I’m concerned about the latest

security news: https://nakedsecurity.sophos.com/2019/05/16/severe-linux-kernel-flaw-found-in-rds/

Hello…as per my knowledge a part of the image includes several predefined files in the /boot directory. To use it you need to rename one of the files in “remote.conf”. Additionally uploaded the site to the directory the deb package “amremote.deb” , which can be installed in the old system.

pcb manufacturing and assembly

The latest versions use the 5.1 kernel. There is no WiFi support for VIM2 Max\Pro yet.

New image version 5.87 20190521

1 Like

Does this one have WiFi support for VIM2 Max\Pro yet?

For the current position on brcmfmac4359 WiFi support please read this post:

3 Likes

Update image version 5.87_20190529

2 Likes

Is it possible to have fan support for the vim2 with the latest Armbian builds? I tried using the fan.sh script from other vim2 Ubuntu builds and older Armbian builds but it doesn’t work with latest kernel. My unit gets warm to hot after about 30min.

If I’m not mistaken, the fan on the main core 5.x should turn on automatically when reaching 80 degrees. (I haven’t checked that in a while.)

It does turn on reaching 80C but it turns off very shortly after, like half a second after it turns on. I prefer for the fan to be on constant like either at low, mid, or high speed if possible.

See the DTS parameters that control the fan. It is possible to manually send the appropriate parameter to the GPIO. Or to build a new DTB with the new values of the temperature of activation.

Update images 5.88_20190607. Fixed sound operation via BT. :slight_smile:

2 Likes

@balbes150 I believe this is the right place to ask my queries. I’m not expert in kernel and O/S level stuff.

Does S905x (2gb 16gb) + Linux O/S supports my requirements?

My requirements:
I’m developing a (video) content display solution to run device in kiosk mode with Chrome browser starting in fullscreen. It is supposed to display video being received.

Now, I’m looking at Amlogic S905x base board to run my solution. Ordered sample S905x based Android TV box from sztomata (OneNuts).
What I need:

  1. Reference, Docs, Scripts to remove Android and load Linux image onto S905x board (eMMC)
  2. Any recommendations on which OS and build to load?
    • Can I use Khadas or corelec images directly on sztomato S905x hardware?
  3. Must work: LAN, Wifi, BLE, USB, HDMI, Video Codecs (H.264, VP8, H.265, VP9)
  4. I do not need Kodi or related TV functionality. There is no video encoding in my solution but does need Video decoding at hw / GPU level
  5. I might need to display say max 4 simultaneous video playback in same browser window

Note: Currently, using Raspberry Pi for development.But Chrome is taking almost 100% CPU while playing a received Video in Chrome browser. But using RPi is very simple:

  1. Flash SD card with Raspbiain Stretch O/S and Load my software
  2. Boot RPi and my solution is ready to use

This is a forum for Khadas products, so it is better to transfer your question to the Armbian forum.

Hey balbes150. Thanks for your work on this!
Just wondering, with the chipset changing to A311D, does your build still work? Sorry if it’s been answered before… I’ve been looking but haven’t found an answer yet.

What would be the best download for me to use on the VIM3? I specifically want Debian, if possible.

Thanks :slight_smile:

As far as I know, a311d is the same version of s922, with the addition of AI. All assemblies for S922 must run on a311d.
@Gouwa can give more information on real testing Armbian of image on VIM3.

Alright great - thanks. So it sounds like I’m on the right track getting my hands on your Armbian_5.89_Aml-s905_Debian_buster_dev_5.2.0-rc4_20190621.img.xz then.

I’ve yet to be able to get it to boot from an SD card. I imaged it to SD and tried booting with the button version boot mode, but it just sits at the Khadas logo indefinitely when I try.

img on eMMC is Ubuntu VIM3_Ubuntu-server-bionic_Linux-4.9_arm64_EMMC_V20190621.img, which works fine.

Any tips to point me in the right direction to boot would be great. Thanks!!