Armbian + KODI (Ubuntu\Debian) for SD & USB & eMMC

There are several options.

  1. Use M-register.
  2. Erase eMMC.

I’ve tried both options already before, i did try to erase emmc, i was following instructions that are on khadas docs, don’t know why but when i rebooted, nothing was erased.

M-register didn’t work at first, i don’t know why, finally today i’ve managed to restore Android using this option.

How can I install the official version of LibreELEC 9.0.1 to EEMC?


Start the system and run the “dd” command, guaranteed to erase u-boot in eMMC and allows you to use the USB Burn Tool.

What exactly image are we talking about ? And better to ask this question in the appropriate topic of Libreelec.

Update image 20190408

Pay attention. In this version, the common image for all s9xxx. The default is DTB for VIM1 (s905x). To run on VIM2 (S912), you need to edit the settings file “uEnv.ini” (to specify the correct dtb).

1 Like

I attempted to test some images from:
I could NOT get
to boot at all; first, when I tried to use Etcher to burn the images to SD Card, they were ignored and I was instead booted into the EMMC (Where I have Khadas’s Official Ubuntu Installed), then when I used HDD-Raw-Copy-Tool from , they wouldn’t boot anything at all, just stayed on a black screen, this was the same method I used to burn and boot
(No Longer Found) which worked and booted up fine.
Why are the other two images not working and giving me problems? Can someone please help me fix this? I tried burning the images 4 different times, on two different OSs, one in Linux Mint, and the other in Windows 10; none of the attempts worked, Only the 20190318 image. Please let me know how I can boot the other images. @balbes150 it’s my understanding you built these images? Why do they not work and why was 20190318 removed?
NOTE: this is all for a Khadas VIM2 Max (First Edition)

Do you read the messages carefully ?

To run on VIM2 (S912), you need to edit the settings file “uEnv.ini” (to specify the correct dtb).

Open the " uEnv.ini" from the SD card that works on your VIM2. Write down on a piece of paper exactly as the name of the DTB file used (the first line in the file). Edit this file in the same way in the images you want to run. You can copy this file and replace it in the new image.

Pay attention. To properly start the system from external media, you must have the latest version of universal multi-boot enabled. If you are using Ubuntu in eMMC, the order of activation of the multi-boot different from the standard descriptions in this thread.

I don’t know what “universal multi-boot” is, where to get it, or how to enable it.
But so far I’ve been able to start the system from external media.

The file ALREADY matched exactly:


I don’t know what changes you’ve made to your VIM2 sample and what system and u-boot it is now. See this information.

See this topic above, there have already been descriptions of problems with running external systems when using Ubuntu in eMMC.

I specifically just checked the launch of the latest images on VIM2 MAX. Everything works fine and the system runs normally from a USB flash drive with a regular Android EMMC.

I’ve had NO problems running
“Armbian_5.77_Aml-s912_Debian_stretch_default_5.0.2_desktop_20190318.img.xz” with Ubuntu in eMMC or even Debian in external system from @numbqq 's
One-stop script set to build Ubuntu/Debian images with Ubuntu in eMMC
so: Debian on SD Card and Ubuntu on eMMC

There is obviously something wrong with the two mentioned images:

All the other images I’ve tested seem to run ok.

Can you please double check the functionality of the images on a VIM2 Max @balbes150 ?

No changes to VIM2 sample. I described running Official Khadas’s Ubuntu in eMMC from image: Whatever u-boot comes on/with that image.

Do you know if Wi-Fi on VIM2 Pro/Max rev 1.4 works with mainline kernel?

I don’t have such a model, so I can only assume. Probably doesn’t work yet, because it uses 6398 , it’s close to 6359. I could be wrong, though. This can update the @Gouwa or @numbqq


Maybe not work, the driver from mainline doesn’t support AP6359SA and AP6398S.

I have asked AMPAK about this issue, they don’t have such firmware, and they point me that it maybe not an issue with firmware, maybe we need more patches to bringup AP6359SA.

Another way is to port bcmdhd driver to mainline…

Hello Oleg,

I have another question to you about the armbian images, how can I use the bluetooth?


Hi Nick
If we are talking about VIM2 , in some versions of images you need to add firmware. This can be done manually or through the standard Armbian mechanism (run the “armbian-config” utility as root and select the full firmware installation menu).

Update image ver 5.78 20190412 (kernel 5.1.0-rc1)


I can’t set the ip_conntrack_max value via sysctl.conf.
It’s just say ‘sysctl: cannot stat /proc/sys/net/ipv4/ip_conntrack_max: No such file or directory’
Please help.
I’m using the armbian running openwrt in docker,
The connection limits is too low,
only 4096…