Armbian + KODI (Ubuntu\Debian) for SD & USB & eMMC

#335

Update images 5.76 20190226. The system now uses the new 5.0 kernel.

2 Likes

#336

Hi balbes,
thanks for your work (and sorry for my poor english).
I’ve actually a khadas vim 1 pro and install the 5.76 armbian server image with kernel 4.2.
Evething work except the wifi.
I didn’t understand how to activate it… is it possible or not?
And if not, wich version of armbian did i install?

Other question.
I also didn’t understand how to udpate an image when armbian is already installed (for ex, kernel 4.2 --> your last update 5.0)

Thanks a lot for your answers

0 Likes

#337
  1. For WiFi to work, check for firmware files. If not, you can copy them manually or install them from the DEB package.
  2. To upgrade the system to the latest kernel version, you can use packages from the DEB directory on the site. But if you have everything running on version 4.20, you can continue to use it.
1 Like

#338

:fu:
work well and after reboot armbian-config integrate the wifi part.
Thank a lot

0 Likes

#339

The new version of the image with the kernel 5.76 5-rc8.

Please note that the image files have replaced the previous versions of the files on the site.

The new kernel adds support for BT on VIM2 (S912), but the BT audio output does not work yet (the sound stutters, you need to change the settings and perhaps the firmware file).

1 Like

#340

New version 5.77.

Please owners of VIM1 Basic to check the work of BT and WiFi with this version.

0 Likes

#341

New version 5.77 (20190318). Updated kernel to 5.0.2. Fixed a bug with the overflow log.

1 Like

#342

I recently flashed Armbian 4.19 mali version on emmc, i didn’t do Android backup because i didn’t have any important data on it.

Now i want to return to Android, but the problem is that my pc doesn’t detect Vim1 usb connection anymore, so i can’t use usb burning tool.

Does this have something to do with newer u-boot that emmc is using now?

I need Android back because i decided to give Vim1 to my brother, i will use my voucher for another Vim.

0 Likes

#343

There are several options.

  1. Use M-register.
  2. Erase eMMC.
0 Likes

#344

I’ve tried both options already before, i did try to erase emmc, i was following instructions that are on khadas docs, don’t know why but when i rebooted, nothing was erased.

M-register didn’t work at first, i don’t know why, finally today i’ve managed to restore Android using this option.

0 Likes

#345

How can I install the official version of LibreELEC 9.0.1 to EEMC?

Thanks!!

0 Likes

#346

Start the system and run the “dd” command, guaranteed to erase u-boot in eMMC and allows you to use the USB Burn Tool.

What exactly image are we talking about ? And better to ask this question in the appropriate topic of Libreelec.
https://forum.khadas.com/t/libreelec-for-khadas-vim-sd-usb-emmc/793/401

0 Likes

#347

Update image 20190408

Pay attention. In this version, the common image for all s9xxx. The default is DTB for VIM1 (s905x). To run on VIM2 (S912), you need to edit the settings file “uEnv.ini” (to specify the correct dtb).

1 Like

#348

I attempted to test some images from: https://disk.yandex.com/d/pHxaRAs-tZiei/5.77/S912
I could NOT get
Armbian_5.77_Aml-s912_Debian_stretch_default_5.0.2_desktop_20190401.img.xz
or
Armbian_5.77_Aml-s912_Debian_stretch_next_5.1.0-rc3-next-20190402-g05d08e299-dirty_desktop.img.xz
from https://disk.yandex.com/d/pHxaRAs-tZiei/5.77/S912/NEXT
to boot at all; first, when I tried to use Etcher to burn the images to SD Card, they were ignored and I was instead booted into the EMMC (Where I have Khadas’s Official Ubuntu Installed), then when I used HDD-Raw-Copy-Tool from http://hddguru.com/software/HDD-Raw-Copy-Tool/ , they wouldn’t boot anything at all, just stayed on a black screen, this was the same method I used to burn and boot
Armbian_5.77_Aml-s912_Debian_stretch_default_5.0.2_desktop_20190318.img.xz
(No Longer Found) which worked and booted up fine.
Why are the other two images not working and giving me problems? Can someone please help me fix this? I tried burning the images 4 different times, on two different OSs, one in Linux Mint, and the other in Windows 10; none of the attempts worked, Only the 20190318 image. Please let me know how I can boot the other images. @balbes150 it’s my understanding you built these images? Why do they not work and why was 20190318 removed?
NOTE: this is all for a Khadas VIM2 Max (First Edition)

0 Likes

3rd Party Armbian Images not Booting
Debian with Kodi
#349

Do you read the messages carefully ?

To run on VIM2 (S912), you need to edit the settings file “uEnv.ini” (to specify the correct dtb).

Open the " uEnv.ini" from the SD card that works on your VIM2. Write down on a piece of paper exactly as the name of the DTB file used (the first line in the file). Edit this file in the same way in the images you want to run. You can copy this file and replace it in the new image.

Pay attention. To properly start the system from external media, you must have the latest version of universal multi-boot enabled. If you are using Ubuntu in eMMC, the order of activation of the multi-boot different from the standard descriptions in this thread.

0 Likes

#350

I don’t know what “universal multi-boot” is, where to get it, or how to enable it.
But so far I’ve been able to start the system from external media.

0 Likes

#351

The file ALREADY matched exactly:


And Still DOES NOT BOOT!

0 Likes

#352

I don’t know what changes you’ve made to your VIM2 sample and what system and u-boot it is now. See this information.

0 Likes

#353

See this topic above, there have already been descriptions of problems with running external systems when using Ubuntu in eMMC.

I specifically just checked the launch of the latest images on VIM2 MAX. Everything works fine and the system runs normally from a USB flash drive with a regular Android EMMC.

0 Likes

#354

I’ve had NO problems running
“Armbian_5.77_Aml-s912_Debian_stretch_default_5.0.2_desktop_20190318.img.xz” with Ubuntu in eMMC or even Debian in external system from @numbqq 's
One-stop script set to build Ubuntu/Debian images with Ubuntu in eMMC
so: Debian on SD Card and Ubuntu on eMMC

There is obviously something wrong with the two mentioned images:
Armbian_5.77_Aml-s912_Debian_stretch_default_5.0.2_desktop_20190401.img.xz
Armbian_5.77_Aml-s912_Debian_stretch_next_5.1.0-rc3-next-20190402-g05d08e299-dirty_desktop.img.xz

All the other images I’ve tested seem to run ok.

Can you please double check the functionality of the images on a VIM2 Max @balbes150 ?

0 Likes