AOSP images are too large to be flashed on VIM3L

Hello all,

I’m trying to build google images and flash them to my VIM3L board.
In order to do so I downloaded and AOSP tree to my Linux machine and i’m using the master.

I do the following steps:

  1. . build/envsetup
  2. lunch yukawa-userdebug
  3. make TARGET_VIM3L=true -j4

After some time I have the images that in theory I should be able to flash on my device but both the boot.img and the recovery,img are too big for the device and i’m unable to flash them.

maxi@ubuntu:~/Desktop/yukawa$ fastboot flash recovery recovery.img
Sending ‘recovery’ (27150 KB) OKAY [ 3.576s]
Writing ‘recovery’ FAILED (remote: ‘Variable not implementedtoo large for partition’)
fastboot: error: Command failed

What am I doing wrong?


Hello @maxi_igo
maybe you can try asking @zonggestsu, he was able to flash his device successfully

good day!

Have you followed the steps with the update tool? I got the same error when I tried to flash it directly

you have to flash the bootloader (uboot) first that is provided in the device/amlogic/yukawa/bootloader folder and frun that with the aml update utility that is linked to in the directions. after that it loads fastboot and you flash the bootloader and clear the environment for the compiled files

1 Like

Hi, thanks for the answer.

Where can I find the update tool?

Just to be sure. I need to flash the uboot first and afterwards I will be able to boot my device in fastboot mode and flash all other images using “fastboot flash”?

and another question, this is what I have in my device/amlogic/yukawa/bootloader folder. which one should I use?

-rw-rw-r-- 1 qateam qateam 1166192 Oct 30 13:15 u-boot_kvim3_ab.bin
-rw-rw-r-- 1 qateam qateam 1152880 Oct 30 13:15 u-boot_kvim3l_ab.bin
-rw-rw-r-- 1 qateam qateam 1150832 Oct 30 13:15 u-boot_kvim3l_noab.bin
-rw-rw-r-- 1 qateam qateam 1164656 Oct 30 13:15 u-boot_kvim3_noab.bin
-rw-rw-r-- 1 qateam qateam 1103728 Oct 30 13:15 u-boot_sei510.bin
-rw-rw-r-- 1 qateam qateam 1104240 Oct 30 13:15 u-boot_sei610_ab.bin
-rw-rw-r-- 1 qateam qateam 1105264 Oct 30 13:15 u-boot_sei610_noab.bin

Follow this guide by starting at first time flashing

1 Like

Many thanks guys, it works like charm!

I have one last question. when i’m using “master” branch in my AOSP repo i’m getting Android 11 tree (make sense as Android 11 is the latest version).
Is there any way to build AOSP images for VIM3L only for Android P or Android 10?

I’ve tried downloading AOSP Android P and Q trees but when using “lunch” no yukawa option is available.