Android Qt_V201223 RTC error

I just noticed in bench testing that my Edge-V MAX did not pull time and date from its RTC.
I have installed a battery so it should.

Is there something I should do so it checks the RTC?

This is for application in a CARPC so access to the internet will not be regular.

Currently on Edge_Qt_V201223

Thank you

@goenjoy please follow up this.

1 Like

Confirmed not working on Edge_Qt_V201223. Worked on a previous QT firmware.

Edited for clarity.

Hmm, I will test again, what I did was simply let the unit set it own time/date via NTP then unpluged from network, shut down and rebooted. No wifi was ever configured only used on eth.

Perhpas I need to manually set time?

My aologies, I did not make myself clear. My confirmation is in agreement with you. RTC is not working on that QT version. Though it worked on a previous QT version.

OH! I see now :slight_smile:
Thank you very much!

@JustSumDad I have verified for many times, but I have not found the problem you mentioned. So you need to check the following two points:
Is the RTC battery socket in good contact?
In addition, can you tell me your specific test steps? Maybe there’s something wrong with your test verification method.

You can test it as follows: plug in the RTC battery, set the right time in the settings, and finally turn off all the power. After waiting for n minutes, turn on the machine and check whether the machine time is consistent with the current time?

1 Like

I checked this yesterday and found it not to be working.
On previous QT firmware settings were,…
Auto timezone: disabled, manually set to my timezone.
Auto time set: enabled.
Time was correctly set on boot.
Test: Disconnect from internet/router. Power down and remove power source for 1 hour. Apply power, boot up and check time.
Result: Time/Date OK. Suggests RTC battery properly connected.

Test on latest QT firmware and no change in RTC connection,…
Time related settings: Same as above.
Test: Same as above.
Result: Time was incorrect, not current.

Goenjoy are you saying time settings need to be set entirely to manual for RTC battery to work latest QT firmware? If so, I will check when I get back.


I am bench testing as well. Thank you

I discovered I had knocked my battery plug loose when I installed the heat sink :frowning:

my bad, so sorry!!!

it does work…

so embarased…

1 Like

My RTC battery is secure. Guess I need to check my work(settings).
If all is well now, it would be a good idea to mark your last post as “Solution”.

No need for embarrassment, likely there are few among us who have not done something similar at one time or another. :slightly_smiling_face:
For me personally, I have been wrong twice in my life…This time, and the time I thought I was wrong, but I wasn’t. :rofl:

1 Like