Android 9 - Failed to Compile

Hi All,
I’ve tried to build Android pie for Vim1 - following the documentation. But it always fail here.

hardware/amlogic/gralloc/ warning: "the value of GPU_TYPE is mali450"
[321/946] including hardware/amlogic/hwcomposer/ ...
"Build HWC 2.0"
[534/946] including system/sepolicy/ ...
system/sepolicy/ warning: BOARD_SEPOLICY_VERS not specified, assuming current platform version
[905/946] including vendor/amlogic/common/LibTsPlayer/ ...
vendor/amlogic/common/LibTsPlayer/jni/media_control/ warning: 9
vendor/amlogic/common/LibTsPlayer/jni/media_control/ warning: 9
vendor/amlogic/common/LibTsPlayer/jni/media_processor/ warning: .
vendor/amlogic/common/LibTsPlayer/jni/media_processor/ warning: 9
vendor/amlogic/common/LibTsPlayer/jni/test/ warning: Kitkat
vendor/amlogic/common/LibTsPlayer/jni/test/ warning: vendor/amlogic/common/LibTsPlayer/jni/test
[914/946] including vendor/amlogic/common/apps/NativeImagePlaye/ ...
vendor/amlogic/common/apps/NativeImagePlaye/jni/ warning: libnativehelper/include_jni
[932/946] including vendor/amlogic/common/frameworks/ ...
vendor/amlogic/common/frameworks/core/jni/screencontrol/ warning: libnativehelper/include_jni
vendor/amlogic/common/frameworks/core/jni/systemcontrol/ warning: libnativehelper/include_jni
[933/946] including vendor/amlogic/common/gpu/lib/ ...
vendor/amlogic/common/gpu/lib/ warning: "the value of BOARD_INSTALL_VULKAN is "
[938/946] including vendor/amlogic/common/prebuilt/ ...
"no bootaccelerate source code, add prebuilts"
"no exoplayer source code, add prebuilts"
vendor/amlogic/common/prebuilt/libmedia/libavenhancements/ error: libamffmpegcodec: No source files specified
build/make/core/ error: done.
23:04:12 ckati failed with: exit status 1

#### failed to build some targets (02:22 (mm:ss)) ####

I’ve tried make clean everything and create base dir and repo from scratch. The error is still occurs.

I can compile Nougat for Vim1, Vim2 on this machine. And I was able to compile Pie few months ago.
Anyone experiencing the same issue?

1 Like

You missing stuff, looks like you sync didn’t go that well.
Maybe some network issues?

1 Like

I’ve checked the missing file - the file is exists on lib (32bit) folder. Funny thing is - the above error is gone after I run build for vim1 Nougat. So I guess there’s some ENV build variable on mine that mistakenly make my compilation as 64bit and when I run build for Vim1 nougat the ENV got overwritten (my build machine is on Google cloud and have multiple source for vim1,vim2 and vim3)

@superceleron - Here’s the repo sync output - after few repo sync run

Skipped fetching project android_system_update_engine (already have persistent ref)
Skipped fetching project android_vendor_amlogic_apps_NativeImagePlayer (already have persistent ref)
Skipped fetching project android_external_bart (already have persistent ref)
Fetching projects: 100% (687/687), done.
Checking out projects: 100% (687/687), done.

Do I need to manually run git lfs pull on some sub-folders or it is handled by repo tool?

yes you do need git lfs
But is weird since that folders are managed by repo just fine when i pulled mine!
Something is messing up the env’s!

1 Like

yep it’s weird indeed :)) I’ve made it to compile it. Thanks @superceleron

There’s only one error on Chromium - for anyone facing the Chromium issue - i run

cd device/khadas/
git lfs pull

Manually and continue to recompile.

1 Like

sorry to break in with a question, but why compile your own when there are ready to use Android images?
I am waiting for my VIM3 Pro just now :slight_smile:

Of course, miracles should not be expected, but everywhere there are pros and cons, try different builds and you will understand. good luck! :wink:

Yep those ready to use Android firmwares are awesome,
I just need to build one myself because I need heavily customized flavor of Android for my specific needs :wink:

Besides - nothing beat learning than over-engineering things.