Amlogic toolchain on OSX

Are there any available Amlogic toolchain binaries for OSX?

Hi, Magapixel:
It seems that there is not available toolchain for OSX yet:

gouwa@Wesion:~/project/khadas/mmallow$ ls prebuilts/gcc/linux-x86/
aarch64  arm  host
gouwa@Wesion:~/project/khadas/mmallow$ ls prebuilts/gcc/darwin-x86/
gouwa@Wesion:~/project/khadas/mmallow$ ls /opt/toolchains/

I’m not quite sure that whether the prebuilts/gcc/darwin-x86/arm is available or not, we compile on Ubuntu with aarch64 toolchain for Khadas VIM.

1 Like

Resources for Amlogic linux:

1 Like

Hi Megapixel,

You can create toolchain by your self. It is not so complex. Please look at repository (latest code on the branch).

I’m not sure that it can be built without changes on the OSX but you can try.

The main AArch64 toolchain:
$ cd products/S9XX-glibc/1.1.2
$ make

The cortex-m3 toolchain for u-boot firmware:
$ cd products/S9XX-glibc/1.1.2
$ make

The armv8-a 32-bit toolchain for 32-bit development:
$ cd products/A9XX-glibc/1.1.2
$ make

Please note that the installation is going to the /opt/toolchain directory an you have to create /opt/toolchain and give permissions to your self.

At least you can look at makefiles for instruction HOW TO CREATE toolchain.

Best Regards,
Andrey K.

1 Like

Thanks Andrey, that’s very helpful.

I’ll give it a try and report back.

Hi Magapixel,

Did you have a chance to build toolchain for OSX?

Andrey K.

I tried for quite a while but there were quite a few code changes required in the source and I ran out of time to keep going.

I ended up just using Ubuntu via a Vagrant virtual machine - it worked fine.