All the time docker nginx crash


#1

Hello i have a big problem on khadas VIM1 pro and Vim2 pro. All khadas, have this same problem.

on this system it worked until recent updates.
VIM1_Ubuntu-xenial_Linux-3.14_mate_arm64_EMMC_2018-05-31.7z

and the docker never worked on it.
VIM1_Ubuntu-xenial_Linux-4.9_mate_arm64_EMMC_2018-05-31.7z](https://dl.khadas.com/Firmware/VIM1/Ubuntu/EMMC/VIM1_Ubuntu-xenial_Linux-4.9_mate_arm64_EMMC_2018-05-31.7z)

on this system it worked until recent updates.
VIM2_Ubuntu-xenial_Linux-3.14_mate_arm64_EMMC_2018-05-31.7z

and the docker never worked on it.
VIM2_Ubuntu-xenial_Linux-4.9_mate_arm64_EMMC_2018-05-31.7z

LOGS.
After reboot device
[27-11-2018 23:54:45.514] [INFO ] [ NGINX] Starting …

[27-11-2018 23:54:45.560] [ERROR] [ NGINX] Failed to spawn process: Error: spawn /usr/local/nginx/sbin/nginx ENOENT

[27-11-2018 23:54:45.584] [ERROR] [ NGINX] Exited with code: -2

[27-11-2018 23:54:45.937] [ERROR] [ start] Error starting webserver and nginx for application: Error: Failed to start

[23-11-2018 18:58:19.567] [INFO ] [ NGINX] Starting …

[23-11-2018 18:58:19.603] [ERROR] [ NGINX] Failed to spawn process: Error: spawn /usr/local/nginx/sbin/nginx ENOENT

[23-11-2018 18:58:19.647] [ERROR] [ NGINX] Exited with code: -2

[23-11-2018 18:58:20.011] [ERROR] [ start] Error starting webserver and nginx for application: Error: Failed to start


23-11-2018 12:24:05.688] [INFO ] [ NGINX] Starting …

[23-11-2018 12:24:05.723] [ERROR] [ NGINX] Failed to spawn process: Error: spawn /usr/local/nginx/sbin/nginx ENOENT

[23-11-2018 12:24:05.741] [ERROR] [ NGINX] Exited with code: -2

[23-11-2018 12:24:06.132] [ERROR] [ start] Error starting webserver and nginx for application: Error: Failed to start

The application starts up, until the system reboots or the service docker restart, it does not start … I do not know if this is due to the same files a month ago, I uploaded the same data and it worked well, now it does not work anymore.

Anyone have this problem?


#2

What do you mean by this? recent updates?


#3

I solved the problem, it was a problem with the docker and the certificate, it was earlier and suddenly stopped, the docker security update.