4K output on LibreELEC


#1

Hi, I’m trying to figure out why I cannot output 4K @ any refresh rate to my 4K TV.

This is what happens when I try setting the resolution to 3840 x 2160:

Things I’ve tried are changing refresh rates, trying different known good cables, tried different 4K TVs, and different HDMI ports.

4K works fine when booted into Android, so it is definitely isolated to LibreELEC, but no one else seems to be having this problem in the LibreELEC forums. I am not sure if it’s an issue specific to the LibreELEC build running on VIM2.


#2

Hi,
Which LibreELEC ROM you installed?

Have fun!


#3

The one here, for the s912


#4

Which one?


#5

My apologies, this is the one I downloaded:


#6

Version KODI-17 have not supported, use the version with KODI-18.


#7

Thanks! Any idea where I can get a LibreELEC build of Kodi 18 that will run directly from an SD/USB? I’ve looked but can’t seem to find one compatible with the VIM2/s912.

Much appreciated


#8

The symbols in the image names
s905 = VIM
s912 = VIM2


#9

Yes, however all the images I see there are version 17. Is there a link to the images for Kodi 18 on here? Or will all images for s912 work without issue for the VIM2 as well? I understand the VIM2 has the s912 chipset, but I wasn’t sure if there were any customizations specifically for the vim2


#10

all images for s912 work without issue for the VIM2


#11

Thanks, balbes. I’ve managed to get 4K working with the VIM2. The maximum refresh rate I can use is 30. If I try anything higher such as 59hz or 60hz, it will be completely blank. Not that much content is above 24fps anyway, but I was wondering if this is expected with this build?