3rd-Party Ubuntu ROM for Khadas VIM


#203

Beta version (20170623).

To ALL
Add image Debian XFCE+KODI
Works for me VIM Pro.

Armbian_5.27_S9xxx_Debian_jessie_3.14.29_xfce_KODI_20170623.img.xz


#204

still crashing for me:
http://paste.ubuntu.com/24934985/
http://paste.ubuntu.com/24934994/
http://paste.ubuntu.com/24934998/


#205

hi there, thanks for your great work.
-> copy xl_p212_2g.dtb to root directory and rename it to dtb.img
this was the missing link…
while booting on khadas vim pro, with keyboard & mouse attached, got some bluetooth errors first.
there were some pixel glitches in the lower scan lines of the hd monitor. but i won’t need it later anyway.
could do update and upgrade
after the first reboot, the screen remains blank.
keeping calm, waiting
et voilà

mainly interested in hardware crypto, io and net performance, and stability for our use case.
testing ethernet, wifi etc. now.

Armbian_5.27_S905X-S912_Debian_jessie_4.9.26+_server_20170519.img


#206
  1. What firmware is in VIM ? I’m testing on the Android-6 (use dtb image kvim.dtb).
  2. You need to use the latest version of the image (20170623), it has all the latest changes.
  3. Once again, pay attention (I specifically wrote about it) - launch KODI needs to be run from the menu (graphics and sound\kodi). If you want to run manually from the terminal , you need to use another command of “kodi-standalone”.

#208

I was running on the official ubuntu mate, I’ll install Android and try again.


#209

A question to all. Someone was able to run the latest image with KODI and test (in General) work with KODI ? I have the impression that it runs solely from me.


#210

Error found in latest version of Armbian+KODI (20170623) and images that can be repaired without downloading a new image (in which these errors are corrected).

  1. Freeze sound. To resolve is to edit the file /etc/pulse/default.pa the line load-module module-udev-detect (remove the tsched=0).

  2. In a lengthy video playback in the main system turns on the screensaver and artefacts to video. The solution is to disable or uninstall the screensaver. Or use a separate graphics desktop and launch KODI. To do this, remove the package “nodm”, install package “lightdm”. This will allow at the entrance of the system to choose which system to run Mate\XFC or KODI. In the upper right corner of the login screen (lightdm) there is a button to select Mate or KODI. To run KODI you need to choose the second option in the menu.


#211

thank you for this images. you are on the way! i’ve tried the debian-version and had the same troubles like the xXx user at the armbian forum. wifi seems to be a problem and there is no way to leave kodi without to unplug the power cord. if it goes back to ambian it shows the desktop 5 times side by side and very blurred …
the next question is how to install for example vdr-vnsi-client because there is no way to install it inside kodi and in synaptic it is for the kodi 15 version in debian, i think …


#212

ran into errors with wifi and ethernet… (hangups)
on Armbian_5.27_S905X-S912_Debian_jessie_4.9.26+server20170519

trying out the “next” version.
Armbian_5.27_S905_Debian_jessie_4.12.0-next-20170516+_server

with the device tree blob for khadas vim, copied into the root directory and renamed as dbt.img
meson-gxl-s905x-khadas-vim.dtb

still stuck on “vim” logo. multiboot activated (didn’t work with updated android 6 and “khadas” logo)
tried with xl_p212_2g.dtb, same result.

applying new vim dbt file to previous rom, (TEST 20170519) didn’t work either.

still waiting for a stable mainline kernel… with usb, ethernet, wifi working “out of the box”.
btw, armbian jessie server would be my prefered platform for headless stuff, such as router, nas etc. with working hw-crypto (openssl, openvpn…)

ok - testing the new kodi build with armbian jessie 3.19 …
bluetooth works, wifi not.

kodi works (kind of) occasional ghost images when screen saver kicks in
exit of kodi lets system hang with black screen
pulseaudio works fine with lipsync output to hdmi-audio
video has a few dropped frames, but nothing to worry about
hardware decoding in x as expected: provided test.mp4 videos quite laggy, as well as youtube, especially in full screen.


#213

with android installed on the emmc, it works flawlessly now, THANKS!!!


#214

how can we get glmark2 to work any Idea?


#215

thank you for your job. i have just a problezm with kodi.
When i want to quit kodi there is a black screen and the box is blocked.

Alt + F1 don’t work, i can’t stop him.

thanks


#216

ver Mate+Kodi 20170625


#217

yes this is this version whit a tvbox MINI MX 2g/16g.

wifi is ok .

  • kodi read all my video but when i quit him i have a black screen.
  • Bt is activate but is not recognize by my phone and don’t see my phone too

thanks


#218
  1. In a new way (20170625) made separate launch Kodi and desktop. I have when exiting Kodi is normal LIGHTDM is enabled and you can perform other operations. 2. Have you tried to connect a new repository to KODI , is to install the required Addons ?

#219
  1. At the core of 4.12 is no support for many elements.
  2. All images Armbian I removed the automatic download of wifi module at system startup. Because it leads to a hang on different models. You need to manually check the correct operation of the module and enter it in the startup file /etc/modules
  3. Video hardware acceleration only works in KODI.

#220

To compile this utility on driver support fb or collect the driver under X with support for GLS.


#221
  1. Choose to run Kodi in sign in mode in Lightdm. Then when you select exit from Kodi system will return to Lightdm
  2. Kodi works with hardware that is configured in the main system. If you need BT to get up his work in the main system.

To all.
The main feature of the use of Kodi in these images - all settings in the Kodi or Linux system you can run almost as usual in Linux. All configuration files and directories Kodi is available for direct editing.


#222

I tried compiling the one you get on sunxi linux, but the code only supports armhf and not arm64.


#223

thank you. I can use kodi now.

  • Do you know how i can activate BT with AP6330 ? BT appear and is ON but the phone is not recognize.
  • Do you know how i can insert other resolution because i use different screen (1360x768, full hd, HD…) ?

thank you