2K Resolution Ubuntu

Which system do you use? Android, Ubuntu, OOWOW or others?

Ubuntu 22.04 from oowow

Which version of system do you use? Khadas official images, self built images, or others?

Please describe your issue below:

2K resolution dont appear in Ubuntu/Gnome Settings 1080p max

Any way to set It?

Can you share the resolutions?

$ cat /sys/class/drm/card0-HDMI-A-1/modes

cat /sys/class/drm/card0-HDMI-A-1/modes

Dont Appear 2K resolution but my screen is 2K

@numbqq any idea about It?

No idea at this moment, we need to find some 2K displays to check.

Is 4k resolution functional? Note: I still don’t see how to choose 2K

Hello @Jart25

Yes, 4K works well. You can set the resolution in system settings.

how have you added support to 4k? Dts + DRM or only dts? Because 2k dont appear me to select :S

You can check the DRM driver. About the 2K resolution we need to check.

Mmm my resolution is 2560x1440p but only can view 2560x1080 support

Using boot_user_args=video=HDMI-A-1:2560x1440@30 or boot_user_args=video=HDMI-A-1:2560x1440@60

Can view my resolution on gnome settings but at select: black screen

46.652707] [drm] build_hdmitx_attr_str:rgb,8bit = 0+8
[ 46.652710] [drm] [meson_hdmitx_encoder_atomic_mode_set]end
[ 46.652712] [drm] am_meson_crtc_atomic_enable:in
[ 46.652715] [drm] am_meson_crtc_atomic_enable: 2560x1440, 0
[ 46.652728] [drm:am_meson_crtc_atomic_enable [aml_drm]] ERROR no matched vout mode
[ 46.653704] [drm] [meson_hdmitx_encoder_atomic_enable]
[ 46.653750] vlock: event MODE_CHANGE_PRE 0
[ 46.653755] DOLBY: vout_notify_callback: VOUT_EVENT_MODE_CHANGE
[ 46.653757] vlock: event MODE_CHANGE
[ 46.653760] vdin0,std_dur:60
[ 46.653762] vsync_pts_inc 1500 1/60
[ 46.653775] [drm] meson_vout_update_mode_name: update vout 1 name 2560x1440.
[ 46.653780] drm_hdmitx_get_tx_hdcp_cap tx hdcp [0]
[ 46.654344] drm_hdmitx_get_rx_hdcp_cap rx hdcp [1]
[ 46.654347] [drm] meson_hdmitx_get_hdcp_request usr_type: 3, hdcp cap: 0,0
[ 46.654349] [drm] [meson_hdmitx_get_hdcp_request]: TX no hdcp key
[ 46.654356] [drm:meson_hdmitx_update_hdcp [aml_drm]] ERROR meet stopped hdcp stat
[ 46.654693] [drm:meson_hdmitx_update_hdcp [aml_drm]] ERROR No valid hdcp mode exit, maybe hdcp havenot init.
[ 48.375810] usb 1-1.2: USB disconnect, device number 3
[ 48.375819] usb 1-1.2.1: USB disconnect, device number 4
[ 48.556361] usb 1-1.2.2: USB disconnect, device number 5

My 1440x2560 (Portrait type) didn’t work at all. Would be awesome if you can add native support.

1 Like

I have tried to add my resolution to aml_media in kernel, but think that It should be added on Uboot, am I on the right way?

Hello @Jart25

We have reproduced on our side, we will check this issue.

Many thanks @numbqq any news?

Hello @Jart25

We need some time to fix this issue, will update here.

I’ve tried the same thing in Wayland as well as using xrandr in Xorg with no luck. I can however show my preferred resolution when parsing ;


I extracted the kvim4.dtb and see some configs for display.

Before I start fiddling, any thoughts about changing some of these hex values?


I’m imagining it’s a similar issue to this.
display_size_default has 1920, 1080, 1920, 2160, and 32 (as hex), with no reference to 2160x1440 resolution (hex 0x5A0) or known memory size for that display size.

Sweet. Thanks for the reference post. I appreciate that!