Will amlogic Linux kernel 4.x be avaiable?


The amlogic openlinux website has many updates, its most update version is 4.9. Will the VIM get updated?



Hi @TonyHo,

I think you are referring to the S905 chip instead of the S905x (VIM). From what I have read in some discussions is that the Khadas Team is busy with a Linux release with 4.x kernel. have a look here:

Also good to read what @balbes150 have done :


Thanks for the quickly reply.
The Android 6/7 in VIM is with Linux 3.14, personally, our project want to use the higher version kernel to port and test with the Bluetooth stack BlueZ, for the Bluetooth LE security connect is mature at least 3.19. So if the higher kernel is out, then, we will save lots of time.


Hi, Tony:
Amlogic still didn’t got linux-4.9 full supported on S905X yet, for example, MALI GPU still doesn’t work at the moment, and this is the reason why Android N still comes with old linux-3.14.


Hi Gouwa. You have access to new source code 2017-03-31 from Amlogic ?


Do you mean buildroot?

No, still buildroot-20170310 here.


5 posts were split to a new topic: DVBSky USB TV Tuner Support

DVBSky USB TV Tuner Support