Wifi power, weaker than phone and laptop


Hi there, i can detect wifi networks on my phone and laptop but i don’t in vim on android.
It is very strange because when i just turned it on it got one or two spots and i had the sad idea of connecting my alfa adapter to the usb.
Since then it only gets my phone hotspot because it’s next to it.
Somebody got a clue?

After it i think i just will flash ubuntu to install the alfa wifi adapter or luckily it’s just plug and play.

Btw i just got my vim today, proud to be part of the community.



Hi, apptizing:
Welcome to our community! :slight_smile:

Regarding the poor WIFI signal problem, can you kindly help to take some photo for us:

  • The WIFI antenna path of main board.
  • The pads of WIFI antenna

Main board with good antenna path:

Bad antenna (The wire doesn’t get in touch with the pad)

Kindly take a check with your VIM, and I will keep following up this. :wink:


Thanks for the reply.
It seems ok, i can upload a pic soon but i think ther is no problem with it because it detects a very near one. It just can’t catch so good as my phone and my laptop built in adapters. Now i have a “bigger” problem cause i tryed to press the buttons at startup and now it’s black and doesn’t boot at all.

I’m a lame user but i hope someone got a clue. I’m willing to make a dual boot or multi with ubuntu but android was fine until now.

I’m gonna shoot myself. :frowning:


You might need to take a look at Khadas Docs for further information, and there are also many other topics you can refer for dual boot.

Good luck!


Thanks again. Already got something to do this weekend.
Btw nice pup in the pic.


Because the Vim uses an IPEX type antenna connector, adding an external antenna is an easy project.

Also, when you get the Vim back on its feet, you can try this change and see if it helps.

From Android go to Settings/More Settings/About TV box and click Build number 4-5 times and it will enable Developer Options.
Back out to Settings/More Settings/ and click Developer Options. Scroll down to the Networking section. Turn on “Use legacy DHCP client”. See if that helps.