USB port malfunction


Can you try to follow the instructions to help catch the printing log and post to us?

1) Setup Serial Tool
2) Power on the VIM and plug any USB device, then catch the printing log.

The system should detect following similar printing(A TOSHIBA USB-Disk here):

[  116.143541] usb 1-1.3: new high-speed USB device number 3 using xhci-hcd
[  116.246779] usb 1-1.3: New USB device found, idVendor=0930, idProduct=6544
[  116.246896] usb 1-1.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[  116.246976] usb 1-1.3: Product: TransMemory     
[  116.247051] usb 1-1.3: Manufacturer: TOSHIBA 
[  116.247126] usb 1-1.3: SerialNumber: C412F52D6C8EC1203002AE2C
[  116.250567] usb 1-1.3: ep 0x81 - rounding interval to 128 microframes, ep desc says 255 microframes
[  116.250724] usb 1-1.3: ep 0x2 - rounding interval to 128 microframes, ep desc says 255 microframes
[  116.253025] usb-storage 1-1.3:1.0: USB Mass Storage device detected
[  116.267240] scsi0 : usb-storage 1-1.3:1.0
[  117.518967] scsi 0:0:0:0: Direct-Access     TOSHIBA  TransMemory      1.00 PQ: 0 ANSI: 4
[  117.534744] sd 0:0:0:0: [sda] 30310400 512-byte logical blocks: (15.5 GB/14.4 GiB)
[  117.535034] sd 0:0:0:0: [sda] Write Protect is off
[  117.535050] sd 0:0:0:0: [sda] Mode Sense: 45 00 00 00
[  117.535329] sd 0:0:0:0: [sda] Write cache: disabled, read cache: enabled, doesn't support DPO or FUA
[  117.537690]  sda: sda1
[  117.539327] sd 0:0:0:0: [sda] Attached SCSI removable disk


Boa tarde!!

Sou um usuário comum uso o vim como box tv, acontece a mesma coisa comigo as postas USB não funcionam, utilizava o vim com um mouse e um controle do xbox 360, agora ele não reconhece mais nada.
Ao ligar o VIM ele inicia o android mas não funciona as USB.


Hi, Josuer:

Does your issue got resolved?

Well, let me paste Google Translate of your issues details here first :smile: :

Good afternoon!!

I am a regular user I use vim as box tv, the same thing happens with me the USB posts do not work, I used vim with a mouse and a control of xbox 360, now it does not recognize anything else.
When connecting the VIM it starts the android but USB does not work.


Boa tarde!! Ainda não continua da mesma forma. O vim funciona normalmente mas as portas USB não.


Does the USB port works fine with other USB devices like USB Disk or USB mouse?

Google translate to Portugues:

A porta USB funciona bem com outros dispositivos USB, como disco USB ou mouse USB?


Não funciona nem com mouse nem com pendrive, mas quando conecto o mouse o sensor do mouse acende mas não funciona.


Google Translate:

It does not work with either mouse or pendrive, but when I connect the mouse the mouse sensor lights up but it does not work.

Can you kindly take a photo when you plug a USB device in the VIM? and kindly try both the two USB ports on your VIM.

Google Translate to Portugues:

Você pode tirar uma foto gentilmente quando você conecta um dispositivo USB no VIM? e experimente as duas portas USB do VIM.



Boa Noite!!
Ainda não consegui resolver meu problema, portas USB não funcionam, atualizei o VIM para o Android OREO mas continua na mesma.

Conforme foto abaixo a luz do mouse acende mas não funciona, pen drive não funciona, teclado não funciona, o que fazer???


Hi, Josuer:
Kindly help to reply below questions one by one:

  • Does your USB mouse don’t works on the two USB ports?
  • Have you tried USB-Disk on VIM?



OI, Gouwa!

  • Ja experimentei o mouse nas duas portas e em nenhuma funcionou.

  • Ja experimentei pen-drive e um hd usb externo nas duas portas e não funcionou.



No idea at the moment, double confirm with you again:

what you tried is USB device like this(USB Disk):

Not someone like this(HDD may need external power supply):


If you have tried out the 1st one above (USB Disk), maybe you can contact the custom service where you bought for further details.


I have VIM1.
Suddenly, I ran into the same problem with the usb host. None of the usb ports works (2 USB, 2 USB devices on the GPIO header). 2 USB ports on the rear panel are normal (5 V), but no more (no devices detected). According to the USB HUB circuits, the U16 chip (FE8.1). It seems that there is a short circuit between the terminals VSS and VDD3F, and the resistance is about 2 ohms. Currently, only the USBOTG port is working.
The next step is to unsolder FE8.1 chip (U16) from the board and check it separately


Infelizmente tive o mesmo problema, possuo o aparelho a 4 meses … Muito pouco para dar problema de curto circuito em placa …


Which model do you have?


Vim1 I have the same problem. Its used now only for tv box hdmi and controlled by remote only


Check your PM for the instructions to move forward.


By the way I’ve noticed another problem(or doubtable design) with USB:
you can’t use GPIO USB and usb socket the same time. If you have a USB device (in my case it’s an external hub) connected via GPIO and you plug in something to the according USB socket on the front - USB device connected via GPIO disconnects.


What kind of usb devices you connected for both GPIO USB and the USB port?


huawei lte modem to usb port, and 7 port Termius hub to gpio. I plug in the modem - hub disconnects. I pull the modem out - hub connects :man_shrugging:


Hello, is the hub self powered?