TWRP on Khadas VIM?


Tried to build u-boot from Marshmallow branch but still no luck - doesn’t load recovery.img neither from SD card nor from USB stick :frowning:

If there is no easy way to fix u-boot, maybe it is possible to unpack update.img, insert custom recovery.img and then pack again to update.img?

@terry @Gouwa


Ok, so I come to conclusion that TWRP for Probox2 is incompatible with Nougat.

What I tried was built Android 7 from sources and packed TWRP as recovery.img into update.img using provided instruction. Then I interrupted Khadas boot via USB to serial prompt and executed

Unfortunately it stopped with exactly the same output as when I was trying to run recovery.img from SD card or USB stick.

So it is most likely not the way how TWRP is executed, but the built TWRP itself - I assume it is not compatible with Nougat.

@Gouwa @terry @balbes150 Any ideas or tips on building TWRP for Khadas VIM Nougat? :slight_smile:


I think you can try to use the latest TWRP on Nougat



Sorry, but I don’t use TWRP. I prefer to use other tools to backup and restore.


I tried to use TWRP for Amlogic p212 (S905X) version from FreakTab but it didn’t run from SD card :frowning:

Probably will try to build from TWRP sources for Amlogic but will most likely need some help getting it run…

Need to mention TWRP for Amlogic p212 (S905X) version works on stock Marshmallow, so again it’s something wrong with Nougat :frowning:


My VIM2 Max has arived yesterday with Android 7.1.2 :slight_smile: I tried TWRP recovery.img on it’s pre-installed ROM and no luck in the same way as I had with Android Nougat built for VIM Pro.

So it looks like Nougat’s uboot or bootloader or something else is unable to load recovery.img from SD card. Please help :neutral_face:


Hi, Gytis:
I’m not familiar with TWRP. I don’t give you more advices about it. I hope other user in forum can help to you.
But I will have a look for TWRP after the weeklong National Day Holida in China.


Would be nice to get it running.

My aim is to have clean Android Nougat ROM, but have TWRP and ZIPs of SuperSU and OpenGApps ready to be installed via TWRP.


@terry Any news? :slight_smile:


I and other guys are still on the Chinese National Holiday, will back at Oct 9. :disappointed_relieved:


How is it that TWRP is so unsupported for the VIM2? I can not believe there is no TWRP. I am replying because I somehow pressed too many buttons on my VIM2 and it would not boot but was “on” when I put power to it. I had to flash the latest “upgrade” of 7.1.2 which wiped my data somehow. Now I have to spend the next 2 days getting it all back in order!