MultiOS_3in1 (Android+Libreelec+Linux) install to eMMC


#184

OK, on libreelec how do I enter the command line?


#185

enable sshd in libreelec settings and ssh into box
(passwd perhaps libreelec or perhaps khadas)
use
fw_printenv bls
to check value.
I assume/recall there is a GUI way to reboot into other OS as well.


#186

Because I changed the theme the buttons with the boot options disappeared, when I reset the original theme was solved.

Can you add the buttons to other themes?


#187

I do not plan such work yet.


#188

Hi Oleg. I watched the world cup soccer game in my Vim2, and Russia gave a terrific 5-0 shower to the other team, with three goals that seemed from another planet. Are you sure you didn’t put any trck in your ROM? :rofl::wink:


#189

Hi, balbes150!
It worked … for some time.
Now, pressing “power” brings the menu to select which system to boot.
But only android fires up. Can’t boot to Ubuntu nor LibreElec.
No way yet to ssh (root, khadas).
How could I update your 3-1 to the newest version?

Thks a lot for your help!


#190

Write in more detail what actions were performed with the system before the reboot stopped working in other systems (installing packages in Android, changing settings, etc.). Try to start the system from an external media (from which you did the installation) and run the command “fw_printenv” from the user “root”, and show the result here.


#191

I had also gathered a problem with the android box. My elder son had set up his google account, installed chrome and a game (terraria).
I use a logitech mouse and keyboard. The interface respond to the mouse. However, action-click didn’t work. Only form the keyboard.
“fw_printenv bls" from another system gave the right info (“libreelec” in my case).
So, with the keyboard, I did a “reset to factory settings” in Nougat. Selected Ubuntu on next boot and it finally did it.
Alas, my khadas account (which I had set to autologin) did not autolog. And no way to enter a password. Had to use root (which is not fully configured). Even after an update, the graphical tools to manage users do not work.
Moreover, I have no clue how to update to your latest 3in1 (no dbbr folder, even in extpart).
On the verge of giving it all up (with the feeling of a “hous of cards”) to install ubuntu with the more user-friendly emmc burning tools.Although not a total noob, I do not have the spare time required to fiddle in what I feel is still a WIP …
Sorry for that!! And thks for your kind interest!


#192

reboot to flash another rom.
cannot enter upgrade mode via keys.
cannot boot anymore (not even the khadas logo)
boot from sd (coreelec) : starts then stop. Was known to work.
boot from usb (libreelec): nothing.
Now bricked.
Fun is over.


#193

I doubt if your box is bricked.
You can always reinstall factory android image and restart experimenting from there.
Good luck!


#194

I guess it’s still working, but I can(t reach upgrade mode…


#195

Finally made it, via TF card update which saved my ass (khadas has none, if I remember well).
Multiboot to reinstall (nothing obvious : still have to find aml_autosript.zip ans time to take care of that - the most difficult part).


#196

All three systems use one common partition (/dev/data) to host user data. If you try to clear data in Android, you erase some (or all) user data from the other two systems (LE and Ubuntu). If you are from under Ubuntu to perform incorrect actions with the data partition, it will also break down the work of the other two systems (Android and Ubuntu). For normal operation of Ubuntu, an important first run, when there is an automatic initial setup (migrating user data in the partition /dev/data). If at this point the process is disrupted, the system will be in an undefined state, with all the ensuing consequences (the khadas user login will not work, etc.). If the primary setting Ubuntu is broken, you will have to perform a number of manual operations to restore (manually delete some parameters\settings and files). Or perform the entire installation procedure from scratch from external media.