HELP! Green Screen! Bricked?


I just attempted to do an upgrade via USB and now my VIM is booting to a blank green screen, and will no longer go into upgrade mode. Did I fully brick it, or is there a way out of this mess? Someone please help!


Hi, gnomefire:
Can you provide us more information about the problem you met now? So we can locate your problem more easy.

Basically, would be better to feedback issues like this:

  • Tell us the ROM version you installed
  • Tell us the hardware date code, i.e. Vim V1.2 1610 4916
  • Describe all the procedures(step-by-step) you did with details
  • Provde neccesarry photos to help us better understand the issue you are facing
  • If you are a developer, post the full printing log
  • Others information you thought would be helpful for us
  • If you are facing many different problems, please create different topics one by one, we will also reply one by one.
  • If your problem has been fixed, please follow the Problem Solved Button to mark it as solved



hello. i’m frenche.
i received one khadas vim pro with android marshmallow.
i flash with a nougat rom with usb and usb burning tool. also i have the khadas screen and a green screen.
after my khadas vim is not reconnize by windows. can you help me please?


Which Nougat ROM version did you install?

You might need try the MRegister Mode.

If your issue still not got resolved, an you kindly take some photos or a simple video to us?

If you are a developer, can you help to post the printing log to us, so we can easy narrow and figure out your issue quickly.
Steps to catch the log:


thanks for your answer.

i have news:
the green screen is not a bricked khadas is just when i try to install vim nougat root 170612.

it is an doc error. count 5 6 sec.

long press Power key without release
Short press Reset key and release
Count 5-6 seconds and release the Power key to enter into upgrade mode.

i try with marshallow root 170303… black screen.

i try with usb burning tool normale and administrator mode, normale erase, all errase…

i try erase all emmc with function button and power buton then reset button.

nothing… but one probleme solved i can flahs my khadas vim.



i install android nougat 7.1.1 in my khadas vim with burning card.

the problem it’s me burn card maker often don’t response. ans i wait 100% but not “the card is done”.
i launch a card burning and i go to sleep. when i wake up the card was perfecly burn.
i try it in my khadas, power button, reset, count five seconde and release power button. upgrade mode, reboot, android 7.1.1. happy end!

so i believe my experience help anybody.

au revoir and thank you!


Congratulations! Glad you got through it. It sure is a good feeling when a device comes back to life. :slight_smile: