Burning Tool no Device


You can go down the list in recovery mode using a USB keyboard. Just make sure you plug in the keyboard before entering “Recovery mode”.

I have tried the erase eMMC that Gouwa reccomended. But now my khadas is only black screen, nothing boots at all.


Strange I did try a USB keyboard and it did not work. Ill try again and give you an update. That is what I am afraid of bricking the device.


Seems my device is now bricked or at least not booting.
Can Khadas team maybe help out?

I tried erase the EMMC.
I think it successfully erased EMMC because now Android Marshmallow is not booting anymore.

What should I do? I am not sure how to enter UPGRADE MODE.


After erasing the emmc storage, you need to upgrade new ROM into VIM.

Actually, it’s not a recommended approach, just one more methods to locate the problem that @gcvanasel met.


I understand it is not recommended but I took this approach as the last resort.
@gcvanasel and I have the same hardware version V1.2 1610 4916 and we are both having issues with this.
I have tried Windows XP, Windows 8 but it never recognises the device for the burning tool.

Now my EMMC is blank I think because nothing boots. What should I press/hold to enter upgrade mode now?


I see that this issue has been addressed a few times already

The MRegister did not work for me I am trying uSD method now and will give an update although you still need to enter Update Mode for this method to work and again we are back to square one…



@gcvanasel did you use the ADB via USB-C cable, or via the wifi/Lan? If via USB, it means that both the USB-C port and the USB-C cable are working, and the most possible reason will comes from the PC side.

Kindly try again with a new PC or Windows XP or Windows 10 :smile:

Don’t be worried about to erase the emmc, the VIM can upgrade via both USB-C cable or a uSD card.


I entered through Ethernet although I have a VIM Media device when in Android and connected to the USB-C so I am sure my PC works and I am sure my USB-C cable works.

There is some other issue here as I have tried on 3 PC’s now and all of them does the same


The different methods I tried to enter upgrade mode;

Method 1

  1. Boot VIM
  2. Press and hold Power
  3. Press reset button quickly
  4. Release power after a few seconds

This gave me “RECOVERY MODE”. Is recovery mode different from “UPGRADE MODE”?
PC does not see the device

Method 2:

MRegister method by short-circuiting the “M”. This did not work either

Method 3:

Erase EMMC, also didnt work to enter upgrade mode. But my EMMC is now blank and I cannot boot.

My main issue now is that we dont know exactly what upgrade mode is, can Khadas show us a picture on what will show on the TV when upgrade mode is connected?


Ok so my device is now exactly in the same place as @barhom doesn’t boot anything screen remains black and when I search for source there is none. I have created uSD with Nougat and it does not boot into “Upgrade Mode”


Connect Success will be showed as below:


Can you enter the Android system? If yes, you can type the adb command .

$ adb shell
$ reboot  update


That doesn’t help us at all. We are referring to what is displayed on the screen connected to the other side of the HDMI coming from VIM. My device is now completely unusable it doesn’t boot into anything it just remains unconnected to the screen…

Why is this such a hassle?


I tried that @terry when I was still able to boot into Android. All that did was reboot the device back into Android


Hello Terry,

I would like to thank you all that you are responding quickly from the Khadas team. This means a lot to the community that you are here to help.

Unfortunately both @gcvanasel and me are still not able to enter the upgrade mode. We still dont know exactly what upgrade mode is since we have never been able to enter it.
Can this be a revision problem from our version V1.2 1610 4916 ?

Now we cannot boot Android at all anymore because the EMMC is blank. What do you suggest?


Just added to @barhom post above I have a new ROM on uSD and it still doesn’t want to boot into Update Mode


When you do the steps entering update mode, but you enter the recovery mode
it has the following several ways

  1. The Amlogic Usb driver was not installed successfully
  2. The Type-C line is broken
  3. The Type-C port on your board is broken.


@barhom you also have VIM 2GB/8GB version? My VIM have also same revision numbers but I ordered 2GB/16GB and i enter every time successful into upgrade mode. On my Monitor i see only three characters “VIM” but Burning Tool does recognize the VIM.

Maybe is there something wrong with non Pro version! For example I cant enter into recovery mode and i don’t know how.

On Android Phone upgrade mode is mostly called “fastboot” and i can enter an Phone into “fastboot” when doing over adb “adb reboot bootloader” , then “fastboot devices” see also that Phone. I can test that tonight with VIM. But yes this will not help you as now you don’t have anything on your eMMC.


Hi Terry,

If the Type-C line or port is broken then how did the device boot in the first place? It does get power although doesn’t enter Update mode


I would like to mention that my windows machine did recognise the Android VIM when it was booted with only USB-C and once Android was fully booted.

This is not the same thing as “UPGRADE MODE” of course, and the second I did the “HOLD POWER, press RESET, release power in 2 seconds” then windows computer gave the sound of unplugging the device and then nothing got plugged in.