Burning Tool no Device


As suggested from @Gouwa please make photo from VIM device.

my VIM enters in upgrade mode when i do following.

  1. start Burning Tool as Administrator
  2. connect HDMI cable to VIM and TV/Monitor
  3. connect usb-c to VIM, and other part to Notebook.
  4. wait until VIM boots and you see Android desktop on your TV/Monitor
  5. press and hold power button (far right button,when having VIM in front of you and HDMI output is on left side), you should see on TV/Monitor reboot/power off menu pop up.
  6. press reboot button (the one on far left) and release after 1 sec.
  7. wait until you see VIM written on your TV/Monitor and count to 5 and release power button, there should be Windows Tone (like connecting usb). And also device manager should show you “WorldCup Devices” under “libusb-win32 USB Devices”, and Burning Tool should see your device to.
  8. follow the instruction like written on page

TWRP on Khadas VIM?

Followed those steps to the T and no luck took photo’s as I went along will post shortly


Sorry for the bad quality photo’s :frowning:

First just a photo of my VIM with the HDMI, USB-C and USB-A connected (Only to VIM)

First Step USB Burning Tool:

Step 2-4 VIM booted into Android

Step 5-7 VIM booted into Recovery Mode

Screen of Device manager at the time of Booting into Recovery

Screen of USB Burner not picking up device

I have tried on 2 PC’s already will try a 3rd tomorrow if I do not get a solution. Killing me


You dont need recovery, but the upgrade mode.
I personally don’t know how to enter into recovery.

Holding power button on VIM and pressing reboot will reboot VIM,when you see VIM written on TV, hold power button for 5 seconds more and release it. ViM will be still written on TV but device will be found on PC.


Not sure I understand you. I though Recovery and Upgrade is the same mode and always have. Does your screen look different to mine then? Doesn’t matter what steps I use I always end up on that screen. Did what you said above and still I am in recovery.


Yes my screen looks different, i just see three characters “VIM”.
What is written on your board which revision and batch?

Buttons position: http://des.gearbest.com/uploads/pdm-desc-pic/Electronic/image/2016/11/16/1479286009487642.jpg


I also see “VIM” for a second (more like a split second) and then it enters Recovery mode. I have loaded firmware to Sony Xperia devices before and they always boot into this mode.

My revision is : V1.2 1610 4916

I really use the correct sequence of buttons


I have same revision. I have VIM Pro (2GB/16GB). but i dont see here recovery menu, which is weird. But when i see VIM on Monitor i count to 5 and release power button and my notebook beeps once (as inserting any USB device). On Monitor nothing more then that “VIM”.

I really don’t know then. I am also just an “user” got my VIM Pro for one week!


Thanks for the help though, perhaps I can get ADB to communicate to the device. Although there is no device picked up in Windows strange


Do you have anything in mSD slot? Also do you have Pro version? and did you tried to flash multiboot rom on it? As my VIM Pro was pre installed with android, and i just upgraded android, i did not flash any multiboot rom.

Here are more procedures how to boot upgrade mode.


Nope I do not have a SD inserted, I have the VIM 2/8gb so not pro and No multiboot this is the first attempt to just load new ROM (New Android) So same as you


If you have serial console cable try to connect and do updates from there.
I am not sure if upgrade==recovery!

I am sure khadas stuff will be able ti write more.


Unfortunately I do not have a serial cable otherwise I would have tried that. Right now it doesn’t even do anything anymore. I can boot into Android yet as soon as I follow the steps. Hold Power + Press Reset and release and wait 3-5 seconds and release power I get a black screen on my monitor. No more Recovery Mode and no more “VIM” written on the screen.


I tried MRegister Mode(Maskrom Mode) same thing screen just goes blank very frustrating.


Is the USB-C suppose to work upside down as well meaning Khadas is pointing to the bottom? When turning upside down the black screen occurs and if Khadas is facing upwards then it enters Recovery


Can you try again with new methods belows:
1) Try to Erase the EMMC first, if the emmc is blank, VIM will boot into upgrade mode automatically when the USB-C cable is connected
2) Try with a new USB-C cable if you have one which is used by mobile phone
3) Try to use uSD card to upgrade for your VIM.

We will follow up this until you got the problem resolved!


Hi @Gouwa thanks for the reply. If I do wipe EMMC and I still cannot connect to VIM would I be able to still update from uSD card? I don’t want to brick my device


I managed to connect to VIM through ADB yet when running the command adb reboot-bootloader it still doesn’t enter “Update Mode”. I am not sure erasing the EMMC will solve my issue


I have the same exact model V1.2 1610 4916.
I cannot seem to enter the “UPGRADE MODE” no matter what I do.

I was able to once put it in “RECOVERY MODE”, but recovery mode is not the same as UPGRADE MODE is it?


Doesn’t seem like it is I always though it is the same thing. If we were able go down on the list in the Recovery mode I could access the device through ADB